Package Details: downgrade 9.0.0-1

Git Clone URL: https://aur.archlinux.org/downgrade.git (read-only, click to copy)
Package Base: downgrade
Description: Bash script for downgrading one or more packages to a version in your cache or the A.L.A.
Upstream URL: https://github.com/pbrisbin/downgrade
Licenses: GPL
Submitter: brisbin33
Maintainer: brisbin33 (atreyasha)
Last Packager: atreyasha
Votes: 579
Popularity: 4.72
First Submitted: 2009-11-12 01:48
Last Updated: 2020-10-29 13:46

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

vinibali commented on 2021-03-15 20:10

Oh, sorry... I missed the target, I was talking about the localepurge :)

brisbin33 commented on 2021-03-15 14:31

vinibali,

Hmm, are you sure?

% curl -L -I https://github.com/pbrisbin/downgrade/archive/v9.0.0.tar.gz
HTTP/2 302 
{snip}

HTTP/2 200 
access-control-allow-origin: https://render.githubusercontent.com
content-disposition: attachment; filename=downgrade-9.0.0.tar.gz
content-security-policy: default-src 'none'; style-src 'unsafe-inline'; sandbox
content-type: application/x-gzip
etag: "b3209e65e127f05cce875595397fee88d4ffbaaaadaee336e9c6f8faf72eb223"
strict-transport-security: max-age=31536000
vary: Authorization,Accept-Encoding
x-content-type-options: nosniff
x-frame-options: deny
x-xss-protection: 1; mode=block
date: Mon, 15 Mar 2021 14:30:36 GMT
x-github-request-id: A724:1C49:ED889:265F28:604F6F8B

vinibali commented on 2021-03-14 18:44

Hello! The URL is not available, 7.3.{4,5,10} is only available. Can you please fix it?

brisbin33 commented on 2020-02-14 20:00

Done.

haawda commented on 2020-02-14 19:38

Can you please do what phillid suggested? Also, please use positive integers for pkgrel, not 0.

Ferdi265 commented on 2020-01-12 12:12

The downgrade script does not yet have support for the new .zst package compression. It just doesn't find packages with that extension.

EDIT: fixed by my PR, will be merged on monday according to pbrisbin

merlock commented on 2019-10-11 22:11

Hi @brisbin33...

Both pacman -Qi and which showed gettext installed.

Re-installed gettext, that seemed to fix the problem.

Don't know if the recent changes to base had anything to do with it.

Thanks for the quick reply!

brisbin33 commented on 2019-10-11 20:12

Hi merlock,

gettext is a package in the base and base-devel groups, which AUR package can assume is installed (i.e. it need not be in dependencies). Somehow you seem to either have lost that package, or something is off with your environment variables?

What does pacman -Qi gettext say? How about which gettext?

merlock commented on 2019-10-11 16:18

Haven't used it for a while, but this happened today:

 downgrade pkgfile
/usr/bin/downgrade: line 3: gettext.sh: No such file or directory
/usr/bin/downgrade: line 36: gettext: command not found


/usr/bin/downgrade: line 142: gettext: command not found
/usr/bin/downgrade: line 140: gettext: command not found
/usr/bin/downgrade: line 142: gettext: command not found
/usr/bin/downgrade: line 140: gettext: command not found
/usr/bin/downgrade: line 142: gettext: command not found
/usr/bin/downgrade: line 140: gettext: command not found
-  1)  pkgfile    19  1  x86_64  ()
-  2)  pkgfile    19  1  x86_64  ()
-  3)  pkgfile    20  1  x86_64  ()
-  4)  pkgfile    20  1  x86_64  ()
+  5)  pkgfile    20  2  x86_64  ()
+  6)  pkgfile    20  2  x86_64  ()

/usr/bin/downgrade: line 46: gettext: command not found

eniac commented on 2019-10-10 16:53

Suddenly I have the same issue as reported by hotice, but my pacman.conf hasn't changed for months.