Package Details: dotnet-sdk-bin 3.1.100-1

Git Clone URL: https://aur.archlinux.org/dotnet-sdk-bin.git (read-only)
Package Base: dotnet-sdk-bin
Description: The .NET Core SDK (binary version)
Upstream URL: https://dotnet.microsoft.com/download/dotnet-core
Licenses: MIT
Provides: dotnet-sdk=3.1.100
Submitter: Gr3q
Maintainer: Gr3q
Last Packager: Gr3q
Votes: 3
Popularity: 1.95
First Submitted: 2019-10-07 08:57
Last Updated: 2019-12-04 17:22

Required by (23)

Sources (3)

Pinned Comments

Gr3q commented on 2019-11-14 20:56

IMPORTANT INSTALLATION INFO (a reminder for myself as well):

For dotnet to work you need to EXPLICITLY install:

ONE dotnet-host - highest version possible
ANY NUMBER of dotnet-runtimes (and its sdks after if you want to build as well - Right now version 'bin' and '2.1' is tested to work together)

If you keep the install order in mind and you don't rely on pacman to resolve your dependencies you will be fine.

Longer explanation:

Every dotnet-sdk is dependent on a specific version of dotnet-runtime, this is built into dotnet.

Technically you only need the latest dotnet-sdk because it can build to any earlier versions.

Because you are installing from the AUR, pacman won't resolve dependencies for you correctly with specific versions, and the installation will either fail or the (outdated) community package will be installed as dependency.

Latest Comments

Gr3q commented on 2019-11-20 17:04

I'm aware that the old version of the SDK remains installed on upgrade, I'm in the process of fixing it

Gr3q commented on 2019-11-14 20:56

IMPORTANT INSTALLATION INFO (a reminder for myself as well):

For dotnet to work you need to EXPLICITLY install:

ONE dotnet-host - highest version possible
ANY NUMBER of dotnet-runtimes (and its sdks after if you want to build as well - Right now version 'bin' and '2.1' is tested to work together)

If you keep the install order in mind and you don't rely on pacman to resolve your dependencies you will be fine.

Longer explanation:

Every dotnet-sdk is dependent on a specific version of dotnet-runtime, this is built into dotnet.

Technically you only need the latest dotnet-sdk because it can build to any earlier versions.

Because you are installing from the AUR, pacman won't resolve dependencies for you correctly with specific versions, and the installation will either fail or the (outdated) community package will be installed as dependency.

Gr3q commented on 2019-10-28 18:44

@sampa82 dotnet-runtime-bin is the AUR package name, it provides dotnet-runtime.

Installing it obviously does not resolve the dependency properly, but the truth is any package what provides 3.0.0 version could be installed as this package's dependency. Changing it to dotnet-runtime-bin would make it exclusive.

sampa82 commented on 2019-10-25 02:20

Although wouldn't it be easier to require for this pkgbuild dotnet-runtime-bin=3.0.0 instead of dotnet-runtime=3.0.0? It seems they are interdependent. Makes installing the sdk a much longer process. Hey just a thought. I'm probably missing something in my understanding.

sampa82 commented on 2019-10-25 02:04

My bad, I fought with the dependencies between the asp runtime and sdk for way longer than I should have. I saw your post on dotnet-runtime-bin at some point today, and it helped a ton. Keep up the good work!

Gr3q commented on 2019-10-23 23:09

Please do flag this package out of date only when there is a new release, not previews or release candidates.

@sampa82 Yeah, this package depends on dotnet-runtime 3.0.0, what the dotnet-runtime package is not. dotnet-runtime-bin provides the required version.

sampa82 commented on 2019-10-23 22:37

Incompatible with the available dotnet-runtime version. I suggest using the package dotnet-runtime-bin instead of dotnet-runtime.

Gr3q commented on 2019-10-09 07:48

@DFS you need to install the aspnet-runtime-bin package. it is optional for the sdk (maybe I should add it as an optional dependency...)

after installing the output should look like this:

.NET Core runtimes installed:
  Microsoft.AspNetCore.App 3.0.0 [/opt/dotnet/shared/Microsoft.AspNetCore.App]
  Microsoft.NETCore.App 3.0.0 [/opt/dotnet/shared/Microsoft.NETCore.App]

If you still have problems after installing it, let me know.

DFS commented on 2019-10-09 07:36

Can't build my ASP.NET Core Application.

[user@host]$ dotnet run It was not possible to find any compatible framework version The specified framework 'Microsoft.AspNetCore.App', version '3.0.0' was not found. - No frameworks were found.

You can resolve the problem by installing the specified framework and/or SDK.

The .NET Core frameworks can be found at: - https://aka.ms/dotnet-download

[user@host]$ dotnet --info Пакет SDK для .NET Core (отражающий любой global.json): Version: 3.0.100 Commit: 04339c3a26

Среда выполнения: OS Name: arch OS Version:
OS Platform: Linux RID: linux-x64 Base Path: /opt/dotnet/sdk/3.0.100/

Host (useful for support): Version: 3.0.0 Commit: 7d57652f33

.NET Core SDKs installed: 3.0.100 [/opt/dotnet/sdk]

.NET Core runtimes installed: Microsoft.NETCore.App 3.0.0 [/opt/dotnet/shared/Microsoft.NETCore.App]

To install additional .NET Core runtimes or SDKs: https://aka.ms/dotnet-download