Package Details: dotnet-host 1:2.0.0-3

Git Clone URL: https://aur.archlinux.org/dotnet-host.git (read-only)
Package Base: dotnet-host
Description: A command line utility for building, testing, packaging and running .NET Core applications and libraries
Upstream URL: https://www.microsoft.com/net/core
Keywords: core dotnet microsoft
Licenses: MIT
Conflicts: dotnet-bin, dotnet-cli
Provides: dotnet-cli
Replaces: dotnet-cli
Submitter: gegenschall
Maintainer: gegenschall
Last Packager: gegenschall
Votes: 28
Popularity: 12.883197
First Submitted: 2017-06-30 12:07
Last Updated: 2017-08-20 12:09

Latest Comments

gegenschall commented on 2017-08-20 12:06

Partly yes, partly no. This package should not have a dependency to openssl-1.0 as the binary in it (ldd /opt/dotnet/dotnet) does not depend on it - but dotnet-runtime-2.0 should. Fixed. Thanks!

xnor commented on 2017-08-18 15:46

@gegenschall
No.
/usr/bin/dotnet is owned by dotnet-host 1:2.0.0-1

`dotnet nuget` fails with:
No usable version of the libssl was found
Aborted (core dumped)

Installing openssl-1.0 provides an openssl version that `dotnet` can use.


I also have the package "dotnet" installed, but this is irrelevant since it doesn't depend on openssl-1.0.

gegenschall commented on 2017-08-15 19:33

dotnet-host should not be installed on its own, it should only be pulled in as a dependency. If you install dotnet, this should work out fine.

xnor commented on 2017-08-15 19:30

Requires a dependency to openssl-1.0 to fix dotnet nuget (which is also run during dotnet-sdk-2.0 installation).

xnor commented on 2017-08-15 19:28

$ dotnet nuget
No usable version of the libssl was found
Aborted (core dumped)

morealaz commented on 2017-07-01 05:02

please add provides=('dotnet-cli') to PKGBUILD