Package Details: doomretro-git 3.6.1.r411.gc4789e48c-1

Git Clone URL: https://aur.archlinux.org/doomretro-git.git (read-only, click to copy)
Package Base: doomretro-git
Description: The classic, refined DOOM source port (git version)
Upstream URL: http://doomretro.com
Licenses: GPL3
Conflicts: doomretro
Provides: doomretro
Submitter: Kaan
Maintainer: FredBezies
Last Packager: FredBezies
Votes: 1
Popularity: 0.000000
First Submitted: 2017-06-20 08:18
Last Updated: 2020-11-14 16:55

Dependencies (5)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

xDShot commented on 2020-06-27 09:40

Shouldn't it pull latest commit instead?

FredBezies commented on 2020-06-27 09:24

Erh...

https://github.com/bradharding/doomretro/releases/tag/v3.5.10

"DOOM Retro v3.5.10

@bradharding bradharding released this 20 days ago · 111 commits to master since this release"

xDShot commented on 2020-06-27 08:38

Weird. Currently latest commit is fa29145e173e1db96bf4532475c4ed19f61df0fc but package version is 3.5.10.r111.gfa29145e1-1

FredBezies commented on 2020-06-27 05:50

@xDShot: worked for me this morning. Just try again :)

xDShot commented on 2020-06-27 02:52

Doesn't clone with latest pushed upstream commit, it appears.

FredBezies commented on 2020-06-08 10:26

@grawlison: So let's follow the holy scriptures... Erh, I mean Arch wiki and some people will think: this package is too old, I have to push an orphan request.

How many messages every month on aur mailing list are related to old vcs PKGBUILD?

I manage this pkgbuild to show everyone it is alive. I don't walk on your feet outdating your doomretro stable pkgbuild.

So let me alone. Thanks.

grawlinson commented on 2020-06-08 10:10

Suffix pkgname with -cvs, -svn, -hg, -darcs, -bzr, -git etc. unless the package fetches a specific release. If the resulting package is different after changing the dependencies, URL, sources, etc. increasing the pkgrel is mandatory. Touching the pkgver is not.

From VCS package guidelines. You should only be uploading to the AUR if the PKGBUILD requires new or updated build steps.

FredBezies commented on 2020-05-30 09:13

I know this. I will stay with point release now. I think you'll be happy!

grawlinson commented on 2020-05-30 09:12

But you don’t need to push an update, that’s the whole point of VCS packages.

FredBezies commented on 2020-05-30 08:57

@grawlison: I know, but when I push an update, it builds.