Package Details: dolfin 2019.1.0.post0-4

Git Clone URL: https://aur.archlinux.org/dolfin.git (read-only, click to copy)
Package Base: dolfin
Description: The C++ interface of FEniCS, providing a consistent PSE (Problem Solving Environment) for ordinary and partial differential equations (stable).
Upstream URL: https://bitbucket.org/fenics-project/dolfin
Licenses: LGPL3
Groups: fenics
Conflicts: dolfin-git
Submitter: sigvald
Maintainer: sigvald (Polly)
Last Packager: sigvald
Votes: 5
Popularity: 0.031756
First Submitted: 2018-01-08 14:06
Last Updated: 2020-06-13 08:17

Dependencies (9)

Required by (3)

Sources (1)

Latest Comments

1 2 Next › Last »

dr460nf1r3 commented on 2021-04-27 08:53

Please add cmake to makedepends, thanks :)

tinux commented on 2021-02-15 10:25

@nw2190 Thank you, your instructions worked perfectly!

nw2190 commented on 2021-02-10 18:24

Sorry for the spam, but I just wanted to provide an update in case anyone else is experiencing this issue; I was able to successfully install the package using the following patches:

https://bitbucket.org/fenics-project/dolfin/issues/1115/compile-error-min_element-is-not-member-of

https://bitbucket.org/fenics-project/dolfin/issues/1110/hdf5interfacecpp-incompatible-with-recent

https://bitbucket.org/fenics-project/dolfin/issues/1116/boost-detail-endianhpp-no-longer-available

In particular, I saved these patches as "min_element.patch", "hdf5.patch", and "endian.patch" then updated the current PKGBUILD sources to:

source=(${pkgname}-${pkgver}.tar.gz::https://bitbucket.org/fenics-project/${_base}/downloads/${_base}-${pkgver}.tar.gz min_element.patch hdf5.patch endian.patch)

and added the following "prepare()" block:

prepare() {

cd "$pkgname-$pkgver"

patch --forward --strip=1 --input="${srcdir}/min_element.patch"

patch --forward --strip=0 --input="${srcdir}/hdf5.patch"

patch --forward --strip=1 --input="${srcdir}/endian.patch"

}

Then updated the checksums and installed the package from the command line using:

makepkg -g >> PKGBUILD

makepkg -si

nw2190 commented on 2021-02-10 15:21

I believe the error is caused by Boost no longer including 'algorithm' as mentioned in the following bug report: https://bitbucket.org/fenics-project/dolfin/issues/1115/compile-error-min_element-is-not-member-of.

It appears that the patch simply consists of manually including 'algorithm' in the "geometry/IntersectionConstruction.cpp" and "mesh/MeshFunction.h" files, and I am working to see if this fixes the issue now.

nw2190 commented on 2021-02-08 17:32

Hi, I have used this package to install dolfin several times in the past, but I am now encountering the following error during the build:

'min_element' is not a member of 'std'; did you mean 'tuple_element'? (which occurs at line 442 of the IntersectionConstruction.cpp file)

I believe this is related to the following bug reported to the Debian Science Team: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=977222. Do you happen to know how this error can be resolved to successfully install the package? Thanks for all of the help maintaining this package!

jvellojin commented on 2020-08-01 02:48

The install with hdf5>=1.12 is possible by editing dolfin/io/HDF5Interface.cpp before (or during) makepkg. The bug has been reported. https://bitbucket.org/fenics-project/dolfin/issues/1110/hdf5interfacecpp-incompatible-with-recent

sigvald commented on 2020-06-13 08:19

@jvellojin: Sorry for the late response on this. I just did as you said, making hdf5 optional, but I do not at the moment have the capacity to test it myself. Testers and co-maintainers welcome.

jvellojin commented on 2020-05-09 19:46

@sigvald: That is correct. dolfin, python-dolfin, mshr and python-mshr are installed without any problems when hdf5 is absent. The current issue is very similar to that of Sundials. Maybe this will not be a problem with the upcoming dolfinx (and related tools). Until then, as a temporary workaround, you can make hdf5 an optional dependency so that the interested user is not forced to install it, and pin a comment here suggesting that hdf5_version<=1.12.0-1 is required.

sigvald commented on 2020-05-07 17:24

@jvellojin: That's unfortunate. So if I understand you correctly, the new HDF5 in the official repo breaks dolfin, regardless of which PETSc version is installed?

I downgraded a package form the official repo once, but it got upgraded again every time I did a routine upgrade of Arch. What I did then was to create a package myself which provided the older version, and which conflicts with the official package such as to prevent both from being installed simultaneously. Not sure what the best way to deal with this actually is. Any ideas?

jvellojin commented on 2020-05-02 18:34

The latest version of hdf5 1.12.0-2 yields to a failed instalation on earlier versions of petsc (e.g. 3.12.4) and later on dolfin (complains about a H50 missing data). On the other hand, petsc 3.13 installs without problems with hdf5 1.12.0-2 but dolfin fails again with the same error. Downgrading petsc/pets4py to 3.12.4 and removing hdf5 as a dependency of dolfin solves the issue (at the expense of not having hdf5). The hdf5 package can be downgraded, but since it is in the official repos, I don't know if it will give future problems.