Package Details: dogecoin-daemon 1.14.3-1

Git Clone URL: https://aur.archlinux.org/dogecoin-daemon.git (read-only, click to copy)
Package Base: dogecoin-daemon
Description: Dogecoin is a peer-to-peer network based digital currency - daemon
Upstream URL: https://dogecoin.com/
Keywords: cryptocurrency dogecoin moon
Licenses: MIT
Conflicts: dogecoin-qt
Submitter: acerix
Maintainer: acerix
Last Packager: acerix
Votes: 13
Popularity: 0.000000
First Submitted: 2014-01-01 23:04
Last Updated: 2021-05-12 01:05

Latest Comments

1 2 Next › Last »

acerix commented on 2021-01-03 20:25

@mike2208 Thanks for putting that together, just applied it

mike2208 commented on 2021-01-03 12:58

dogecoin-daemon build fails due to missing include headers. The following git patch applies the patches found in the AUR package dogecoin-qt and fixes the issue:

From cba03c5554b48af864303d9e63024a9536ca4afd Mon Sep 17 00:00:00 2001
From: Michael <mike09402@gmail.com>
Date: Sun, 3 Jan 2021 13:17:51 +0100
Subject: [PATCH] Added patches from AUR pkg dogecoin-qt

---
 PKGBUILD           | 16 +++++++--
 boost.patch        | 81 ++++++++++++++++++++++++++++++++++++++++++++++
 deque.patch        | 11 +++++++
 qpainterpath.patch | 11 +++++++
 4 files changed, 117 insertions(+), 2 deletions(-)
 create mode 100644 boost.patch
 create mode 100644 deque.patch
 create mode 100644 qpainterpath.patch

diff --git a/PKGBUILD b/PKGBUILD
index c244bc1..e7f33af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,15 +10,26 @@ makedepends=('boost' 'libevent' 'zeromq')
 license=('MIT')
 source=("$pkgname-$pkgver.tar.gz::https://github.com/$_pkgbase/$_pkgbase/archive/v$pkgver.tar.gz"
         "dogecoin.sysusers"
-        "dogecoin.tmpfiles")
+        "dogecoin.tmpfiles"
+        "boost.patch"
+        "deque.patch"
+        "qpainterpath.patch")
 sha256sums=('416581d0af2df05ededb400b9434765eeaeb1396c9f3ef80a7b59a88c74a90cc'
             'eae13ea082a6431bb9552b5bddd8d1a5100ba883540c1e520685272d4307ca7f'
-            'eaf022a60cb3297a31148b047bd473eef5bb08ec011f6ed29869061a03342d94')
+            'eaf022a60cb3297a31148b047bd473eef5bb08ec011f6ed29869061a03342d94'
+            'e6d3eef4e71719afd748bfd312955c32bc50b3ea2b0a92297e6982b42b0c210e'
+            '792f4073d0de5017c9750a5f4a653759a79020d0de69e60320fcba0e4030005a'
+            '1d503bd528f960a863f702a87a7ae283b6f6b29050b7faa552c3967514b0ece9')
+
 validpgpkeys=('1DDC450B45DB5ADCCF5DDA7F8E4217C6D47D946D')

 prepare() {
   cd "$_pkgbase-$pkgver"
   autoreconf -fi
+
+  patch -p2 <$srcdir/deque.patch
+  patch -p1 <$srcdir/qpainterpath.patch
+  patch -p2 <$srcdir/boost.patch
 }

 build() {
@@ -30,6 +41,7 @@ build() {
 package_dogecoin-daemon() {
   pkgdesc="Dogecoin is a peer-to-peer network based digital currency - daemon"
   depends=(boost-libs libevent zeromq)
+  conflicts=(dogecoin-qt)

   cd $_pkgbase-$pkgver
   install -Dm755 src/dogecoind "$pkgdir"/usr/bin/dogecoind
diff --git a/boost.patch b/boost.patch
new file mode 100644
index 0000000..350a3f8
--- /dev/null
+++ b/boost.patch
@@ -0,0 +1,81 @@
+diff -ur src2/dogecoin-1.14.2/src/validation.cpp src/dogecoin-1.14.2/src/validation.cpp
+--- src2/dogecoin-1.14.2/src/validation.cpp    2019-04-08 14:28:20.000000000 +0700
++++ src/dogecoin-1.14.2/src/validation.cpp 2020-02-03 18:31:55.196768990 +0700
+@@ -44,6 +44,7 @@
+
+ #include <boost/algorithm/string/replace.hpp>
+ #include <boost/algorithm/string/join.hpp>
++#include <boost/bind.hpp>
+ #include <boost/filesystem.hpp>
+ #include <boost/filesystem/fstream.hpp>
+ #include <boost/math/distributions/poisson.hpp>
+
+--- src2/dogecoin-1.14.2/src/validationinterface.cpp    2020-12-22 05:09:29.305584746 -0800
++++ src/dogecoin-1.14.2/src/validationinterface.cpp     2020-12-22 04:55:54.489730962 -0800
+@@ -5,6 +5,8 @@
+
+ #include "validationinterface.h"
+
++#include <boost/bind.hpp>
++
+ static CMainSignals g_signals;
+
+ CMainSignals& GetMainSignals()
+
+--- src2/dogecoin-1.14.2/src/qt/bitcoingui.cpp     2020-12-22 05:14:22.863474268 -0800
++++ src2/dogecoin-1.14.2/src/qt/bitcoingui.cpp      2020-12-22 05:05:15.267433930 -0800
+@@ -38,6 +38,8 @@
+
+ #include <iostream>
+
++#include <boost/bind.hpp>
++
+ #include <QAction>
+ #include <QApplication>
+ #include <QDateTime>
+
+--- src2/dogecoin-1.14.2/src/qt/clientmodel.cpp    2020-12-22 05:14:33.973393228 -0800
++++ src2/dogecoin-1.14.2/src/qt/clientmodel.cpp     2020-12-22 05:05:34.335287787 -0800
+@@ -21,6 +21,8 @@
+
+ #include <stdint.h>
+
++#include <boost/bind.hpp>
++
+ #include <QDebug>
+ #include <QTimer>
+
+--- src2/dogecoin-1.14.2/src/qt/splashscreen.cpp   2020-12-22 05:14:44.537316110 -0800
++++ src2/dogecoin-1.14.2/src/qt/splashscreen.cpp    2020-12-22 05:05:50.163166476 -0800
+@@ -20,6 +20,8 @@
+ #include "wallet/wallet.h"
+ #endif
+
++#include <boost/bind.hpp>
++
+ #include <QApplication>
+ #include <QCloseEvent>
+ #include <QDesktopWidget>
+
+--- src2/dogecoin-1.14.2/src/qt/transactiontablemodel.cpp  2020-12-22 05:14:54.453243665 -0800
++++ src2/dogecoin-1.14.2/src/qt/transactiontablemodel.cpp   2020-12-22 05:06:09.833015722 -0800
+@@ -26,6 +26,7 @@
+ #include <QIcon>
+ #include <QList>
+
++#include <boost/bind.hpp>
+ #include <boost/foreach.hpp>
+
+ // Amount column is right-aligned it contains numbers
+
+--- src2/dogecoin-1.14.2/src/qt/walletmodel.cpp    2020-12-22 05:15:01.839189671 -0800
++++ src2/dogecoin-1.14.2/src/qt/walletmodel.cpp     2020-12-22 05:06:28.748870741 -0800
+@@ -28,6 +28,7 @@
+ #include <QSet>
+ #include <QTimer>
+
++#include <boost/bind.hpp>
+ #include <boost/foreach.hpp>
+
+ WalletModel::WalletModel(const PlatformStyle *platformStyle, CWallet *_wallet, OptionsModel *_optionsModel, QObject *parent) :
+
diff --git a/deque.patch b/deque.patch
new file mode 100644
index 0000000..293723e
--- /dev/null
+++ b/deque.patch
@@ -0,0 +1,11 @@
+diff -ur src2/dogecoin-1.14.2/src/httpserver.cpp src/dogecoin-1.14.2/src/httpserver.cpp
+--- src2/dogecoin-1.14.2/src/httpserver.cpp    2019-04-08 14:28:20.000000000 +0700
++++ src/dogecoin-1.14.2/src/httpserver.cpp 2020-02-03 18:31:55.196768990 +0700
+@@ -19,6 +19,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <signal.h>
++#include <deque>
+ #include <future>
+
+ #include <event2/event.h>
diff --git a/qpainterpath.patch b/qpainterpath.patch
new file mode 100644
index 0000000..d0e2ffd
--- /dev/null
+++ b/qpainterpath.patch
@@ -0,0 +1,11 @@
+diff --git a/src/qt/trafficgraphwidget.cpp b/src/qt/trafficgraphwidget.cpp
+--- a/src/qt/trafficgraphwidget.cpp
++++ b/src/qt/trafficgraphwidget.cpp
+@@ -6,6 +6,7 @@
+ #include "clientmodel.h"
+
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QColor>
+ #include <QTimer
+
--
2.30.0

Download and run git apply to apply the patch.

ozz commented on 2018-06-04 12:00

The incompatible bdb does cause issues if you're moving the blockchain around between clients. There is an AUR for db5.1 that coexists with other versions.

automoc4 and protobuf probably shouldn't be dependencies since they are related to the GUI which is disabled.

acerix commented on 2018-04-02 16:21

How is libressl a dependency? That is an "EXPERIMENTAL" package in AUR and the latest stable release of dogecoin (1.10) seems to need openssl 1.0 to compile, otherwise I get "configure: error: Detected LibreSSL: This is NOT supported, and may break consensus compatibility!".

muhviehstarr commented on 2018-04-02 11:15

add libressl to depends

mmozeiko commented on 2015-10-07 05:24

Makes sense. Thanks.

acerix commented on 2015-10-06 23:22

Thanks, I suggested the patch upstream: https://github.com/dogecoin/dogecoin/issues/1292

For this package though, I changed it to compile without UPNP as I'm pretty sure anyone using this daemon doesn't actually want automatic port forwarding.

mmozeiko commented on 2015-10-05 05:24

After miniupnpc upgrade to 1.9.20150730-1 version follwing patch is needed to compile source: https://github.com/bitcoin/bitcoin/commit/9f3e48e5219a09b5ddfd6883d1f0498910eff4b6.patch

2mac commented on 2014-04-09 15:27

Tried starting with `dogecoind` but was never able to access the server.

spudospard commented on 2014-02-28 17:10

Good job acerix, thank you