Package Details: docfetcher 1.1.22-3

Git Clone URL: https://aur.archlinux.org/docfetcher.git (read-only, click to copy)
Package Base: docfetcher
Description: A java open source desktop search application
Upstream URL: http://docfetcher.sourceforge.net/
Keywords: desktop productivity search
Licenses: EPL
Submitter: thiagowfx
Maintainer: macxcool
Last Packager: macxcool
Votes: 17
Popularity: 0.000014
First Submitted: 2014-05-01 20:55
Last Updated: 2020-05-01 11:43

Dependencies (4)

Required by (0)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

pitlochry commented on 2016-10-28 10:30

@http://hastebin.com/arubabakoq.bash

I use kde, so $_gtkver gives nothing (at least on my system).

So there is no link made.

thiagowfx commented on 2016-10-24 05:19

LGTM

macxcool commented on 2016-10-23 18:57

What do y'all think of this? http://hastebin.com/arubabakoq.bash

thiagowfx commented on 2016-10-23 16:59

I am not currently using this software, so I can't advise.

However, I'd say it's better to stick to one and only one. Choose gtk2 or gtk3, whatever you think it's more convenient. Since Arch supports gnome, which uses gtk3, I guess it would be a good default choice to make it more consistent with the rest of the system.

And, if changing it to gtk2 is just a matter of changing one flag (like --use-gtk2 instead of --use-gtk3), then you could leave a comment so users can change it at their own discretion.

All right?

macxcool commented on 2016-10-23 13:04

OK. Which of the two should we be using, or should we make both available?
I also notice that both DocFetcher.GTK2 and DocFetcher.GTK3 are not chmod +x by default.
Should we just use GTK3 by default? I suggest a symlink called DocFetcher.sh to DocFetcher.GTK3 then? That's somewhat simpler and allows for an easy change to GTK2 for the user.
We should also make GTK3 a dependency, shouldn't we?

davidmcinnis commented on 2016-09-14 05:10

Had to make the following change for docfetcher to start:

docfetcher
@@ -1,3 +1,3 @@
#!/bin/sh
cd "/usr/share/docfetcher/"
-exec ./DocFetcher.sh "$@"
+exec ./DocFetcher-GTK3.sh "$@"

thiagowfx commented on 2016-09-10 02:02

yes!

macxcool commented on 2016-09-09 16:28

Thx. I didn't realize there was a new version out ;-)
Is the PKGBUILD adequate?

thiagowfx commented on 2016-09-09 16:23

bumped to 1.1.18

macxcool commented on 2016-05-14 15:16

I've updated to 1.1.17 and added a basic .desktop file. Please post if there are any problems.