Package Details: dnieremote-bin 1.0-3

Git Clone URL: https://aur.archlinux.org/dnieremote-bin.git (read-only, click to copy)
Package Base: dnieremote-bin
Description: DNIeRemote enable to use the smartphone as reader for Spanish DNI
Upstream URL: https://www.dnielectronico.es/
Keywords: dni dnieremote dniremote electronico remote
Licenses: custom
Submitter: ravens
Maintainer: ravens (ogarcia)
Last Packager: ravens
Votes: 2
Popularity: 0.020681
First Submitted: 2020-06-02 21:32
Last Updated: 2021-01-12 18:57

Pinned Comments

tonitc commented on 2020-12-07 12:08

Como 'workaround' podemos evitar el error arrancando firefox con LD_PRELOAD y libuuid:

LD_PRELOAD=/usr/lib/libuuid.so.1.3.0 firefox

ogarcia commented on 2020-10-24 12:49

La versión actual de dnieremote hace fallar a Firefox con este error:

/usr/lib/firefox/firefox: symbol lookup error: /lib/libdnieremotepkcs11.so: undefined symbol: uuid_generate
Exiting due to channel error.

Es un problema del upstream. Estamos intentando contactar con la oficina técnica del DNIe para ver si podemos sacar el origen del error. Según vayamos avanzando en la investigación os iremos poniendo aquí las actualizaciones. Disculpar las molestias.

ogarcia commented on 2020-10-24 12:32

WARNING: The libs of this package are in /usr/lib/ instead of /usr/local/lib as says the "manual".

ATENCIÓN: Las librerías de este paquete están en /usr/lib/ en lugar de /usr/local/lib como indica el "manual".

Latest Comments

1 2 3 Next › Last »

ogarcia commented on 2021-04-14 15:05

He creado un paquete nuevo de autofirma autofirma-bin. Ojo, no lo he podido probar con DNI Remote porque mi DNI tiene los certificados caducadisisimos, pero con un certificado de la FNMT funciona perfecto.

La motivación de hacer un paquete nuevo es por dos razones, la primera es que el nombre del que ya había en AUR debería ser -bin y la segunda es que he hecho un paquete mucho mas limpio.

usuariopolivalen commented on 2021-04-06 18:38

Nada, he probado de nuevo y sigue sin funcionar. Autofirma no carga los certificados mientras que firefox si que hace cosas con dnieremote. Autofirmaja lo consigo hacer funcionar con la versión 8 de java

tonitc commented on 2021-01-14 13:32

Al cargar, AutoFirma me da estos datos:

Sistema operativo: Linux Version del SO: 5.10.2-2-MANJARO Version de Java: 1.8.0_265 Arquitectura del JRE: 64 Java Vendor: Oracle Corporation Localizacion por defecto: es_ES

Sigo sin poder firmar con dnieremote y el certificado de firma del dnie. Ni con AutoFirma ni usando Libreoffice.

Pensé que el crash podría estar en la parte de la app móvil, pero por lo que he visto, se estrella en la parte del binario linux (dnieremotewizard) : afirma.desktop[84281]: es.gob.afirma.core.AOException: Error durante la firma PAdES: es.gob.afirma.core.AOException: Error durante el proceso de firma PKCS#1: java.security.ProviderException: sun.security.pkcs11.wrapper.PKCS11Exception: CKR_FUNCTION_FAILED

usuariopolivalen commented on 2021-01-14 13:24

@ravens ya estásolucionado los links, gracias. Lo que si, me sigue dando los mismos errores. @tonitc Tú como has logrado hacer funcionar autofirma con dnieremote, con que versión de java exacta? Porque no me va con ninguna...

usuariopolivalen commented on 2021-01-12 11:37

@ogarcia también una pregunta porque las librerias se ponen en un sitio distinto al que deberían ir?

usuariopolivalen commented on 2021-01-12 11:36

https://github.com/ctt-gob-es/clienteafirma/issues/152

Aquí he dejado varios reportescon distintas versionesde java y distintas de autofirma( la de autofirmaja que es de la junta)

usuariopolivalen commented on 2021-01-12 11:35

a ver, a mi autofirma, no me va. No coge ningun certificado, solo me va autofirmaJA la version de la juntaa de andalucía y SOLO con la versión 1.8 de java versión oficial JRE8 el paquete de aur. Y en cualquier caso tengo que cargar la librería .so.0 o .so.0.0.2 porque la .so me da error al cargar( puesto que está mal linkeada en el pkgbuild creo)

A ver si alguien me arroja un poco de luz... porque abajo dicen que si les funciona autofirma al menos para autenticar, pero a mi ni eso, y he probado con muuuuchas versiones de java, y ni una eh.

ravens commented on 2021-01-12 00:14

@agm28011997 Creo que no usa java el paquete, estoy desde el móvil y no puedo darte respuesta. En teoría el pkgbuild funciona correctamente y la ultima version funciona también correctamente

usuariopolivalen commented on 2021-01-12 00:04

que version de java usais?

usuariopolivalen commented on 2021-01-11 23:39

creo que el paquete tiene fallos en el pkgbuild,¿ podria ser?