Package Details: dive 0.8.1-1

Git Clone URL: https://aur.archlinux.org/dive.git (read-only)
Package Base: dive
Description: A tool for exploring each layer in a docker image
Upstream URL: https://github.com/wagoodman/dive
Keywords: docker
Licenses: MIT
Conflicts: dive-git
Submitter: starkers
Maintainer: dbirks
Last Packager: dbirks
Votes: 7
Popularity: 0.752049
First Submitted: 2018-10-31 22:13
Last Updated: 2019-09-07 14:45

Latest Comments

1 2 Next › Last »

Thrilleratplay commented on 2019-09-16 12:16

I believe this pending PR is relevant to the error we are all getting with Go 1.13

https://github.com/wagoodman/dive/pull/227

mlamm commented on 2019-09-16 08:17

Same here, compiling with go 1.13.

Building via yaourt and also manually cloning the project from github failed for me with:

github.com/go-critic/go-critic@v0.0.0-20181204210945-1df300866540: invalid pseudo-version: does not match version-control timestamp (2019-05-26T07:48:19Z)

Afterwards, I looked for any ~/.go, ~/go directories, nuked them all, now I am getting the same error as in https://aur.archlinux.org/packages/dive/#comment-707166

starkers commented on 2019-09-12 11:34

Just a thought.. I'm on a fresh arch install right now.. and I had no luck replicating the issue.. so I can only assume its down to local config somehow?

dive seems to have a go.mod which is good.. ...could it be as simple as ensuring that we export GO111MODULE=on in build() ?

I'm not entirely sure if peoples local GOPATH could be used by the build but maybe just ensuring that GO111MODULE is on would help some users?

lotia commented on 2019-09-12 07:18

This may well be due to a transitive dependency failing to compile with go 1.13. Would be good to see if people experiencing this problem are also compiling with go 1.13.

The following github issue about golangci-lint may be of use since that was the error I was seeing when attempting to update dive. dive depends on golangci-lint which in turn depends on go-critic.

https://github.com/golangci/golangci-lint/issues/659

JoeCool commented on 2019-09-11 23:46

I am getting a different error when trying to upgrade from 0.7.2-1 ==> 0.8.1-1

==> Starting build()...
go: github.com/golangci/golangci-lint@v1.17.1 requires
github.com/go-critic/go-critic@v0.0.0-20181204210945-1df300866540: invalid pseudo-version: does not match version-control timestamp (2019-05-26T07:48:19Z)
==> ERROR: A failure occurred in build().
Aborting...

aroc commented on 2019-09-11 06:10

@dbirks Is there any information that can help you reproduce the error?

dbirks commented on 2019-09-10 18:19

Just an update: I'm trying to reproduce and fix the error that lots of people are getting right now.

dbirks commented on 2019-09-10 18:17

@aroc I'm glad it's been helpful. And as for not using the makefile, I only did that to be able to inject the version number.

aroc commented on 2019-09-10 17:40

@adequate Exactly the same error and situation.

johnramsden commented on 2019-09-08 22:25

@adequate I'm getting it as well.