Package Details: discord 0.0.5-4

Git Clone URL: https://aur.archlinux.org/discord.git (read-only)
Package Base: discord
Description: All-in-one voice and text chat for gamers that's free and secure.
Upstream URL: https://discordapp.com/
Keywords: chat voice voip
Licenses: custom
Submitter: cazzar
Maintainer: Morganamilo (pezz, E5ten)
Last Packager: E5ten
Votes: 338
Popularity: 29.539108
First Submitted: 2017-01-11 04:55
Last Updated: 2018-06-15 05:57

Pinned Comments

Morganamilo commented on 2018-05-01 19:51

Please report issues with Discord itself to https://discord.gg/discord-testers or https://discord.gg/discord-linux.

Report any issues relating to the AUR package here.

Latest Comments

FromSi commented on 2018-07-16 13:26

If error of libc++: gpg --recv-keys 474E22316ABF4785A88C6E8EA2C794A986419D8A

Here there is detailed information: https://aur.archlinux.org/packages/libc%2B%2B/#comment-654129

leodag commented on 2018-07-06 21:15

Just a small permission inconsistency in the package: /usr/share/applications/discord.desktop is executable, since it has the default install mode of 755. You should supply -m 644 to that install call for the correct mode.

Thaodan commented on 2018-07-06 08:59

You still want a scrit that removes stuff as root in /home? Thats malicius.

Omnitect commented on 2018-06-25 03:06

@tadly, I've been running rofi for a while now, but hadn't seen that icons setting, thanks! I'm also having trouble due to the libc++ dependency not being able to be met.

Ashtez commented on 2018-06-22 15:00

On Manjaro I just had to use the gpg --recv-keys command, then it runs fine.

Iusildra commented on 2018-06-17 19:40

Discord's installation won't work because of libc++ test's failure.

I tried to install discord from the AUR (libc++'s compil failed during the check phase. The exit codes of the tests were -6...).

But I also tried to install discord from local source with discord-0.0.5.tar.gz and I got a message saying that there was missing metadatas and that the pkg is invalid or corrupted

Oczkins92 commented on 2018-06-15 13:07

@kikuaknight Please use this command: gpg --recv-keys 0FC3042E345AD05D and try again

Strit commented on 2018-06-15 08:27

@kikuaknight That is not Discord related at all. That is libc++ related, so look at the AUR page for that package for fixes: https://aur.archlinux.org/packages/libc++

kikutaknight commented on 2018-06-15 07:15

I'm getting errors when trying to install from Manjaro Gnome - Add/Remove Software:

==> Verifying source file signatures with gpg... llvm-6.0.0.src.tar.xz ... FAILED (unknown public key 0FC3042E345AD05D) libcxx-6.0.0.src.tar.xz ... FAILED (unknown public key 0FC3042E345AD05D) libcxxabi-6.0.0.src.tar.xz ... FAILED (unknown public key 0FC3042E345AD05D) ==> ERROR: One or more PGP signatures could not be verified!

Morganamilo commented on 2018-06-05 18:42

In the past there's been tons and tons of reports of discord wanting to update even though it's been updated. This issue persists until you manually clean discord cache dirs.

That's what the install file is meant to solve, and since adding it I've not heard any complaints.

The automatic pkill on Discord is annoying and I would prefer it to not be there. But the file comes from upsteam to I'm leaving it as it.

discord-{ptb,canary} don't have the install script if you want to use those.

All comments