Package Details: discord-rpc-api-static 3.4.0-0

Git Clone URL: https://aur.archlinux.org/discord-rpc-api.git (read-only, click to copy)
Package Base: discord-rpc-api
Description: Libraries for Discord Rich Presence
Upstream URL: https://github.com/discordapp/discord-rpc
Licenses: MIT
Conflicts: discord-rpc-api
Submitter: vicr123
Maintainer: vicr123
Last Packager: vicr123
Votes: 1
Popularity: 0.000000
First Submitted: 2017-11-30 03:34
Last Updated: 2019-11-04 13:53

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

micwoj92 commented on 2021-05-17 07:34

There are many (especially python and python2) split packages in AUR, it's just that these usually don't conflict with each other. -i tells makepkg to also install all built packages, makepkg then install either discord-rpc-api-static or discord-rpc-api using pacman -U $pkgname

Xudmud commented on 2021-05-17 07:29

First time encountering a split package, didn't realize it was more complicated than running makepkg -si to build those.

micwoj92 commented on 2021-05-17 07:04

@Xudmud learn how split packages work and how to use makepkg.

Xudmud commented on 2021-05-17 07:02

It seems that the PKGBUILD script is trying to build both discord-rpc-api and discord-rpc-api-static which causes the following error message:

error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: discord-rpc-api-static and discord-rpc-api are in conflict

Looking in the PKGBUILD script it seems that it does try to build both packages and then install them through pacman.

edit: Need to learn how stuff works apparently.

vicr123 commented on 2018-07-01 07:08

Alright, I've updated the PKGBUILD. Thanks :)

Wild commented on 2018-06-26 23:08

Seems like they have removed the pregenerated Makefile, also the current PKGBUILD did something crazy with the lib64 thing.

Here is my PKGBUILD that uses cmake to build the project, like they say in the instructions. http://definewild.se/public/discord-rpc-api-PKGBUILD

vicr123 commented on 2018-06-25 12:02

Hmm, I don't seem to be having that issue...

Can you please delete the folder that you downloaded the PKGBUILD to (including the pkg and src folders) and try again? For some reason it seems like it's not executing the build instructions :/

vicr123 commented on 2018-06-25 08:53

My apologies, let me look into that

nfsgraine commented on 2018-06-22 08:42

Same problem as user curtisbelt.

curtisbelt commented on 2018-06-06 17:57

Hello, getting an error when upgrading from 3.3.0-0 to 3.3.0-1:

make: *** No rule to make target 'install'. Stop. ==> ERROR: A failure occurred in package().

Full log ---

Building discord-rpc-api... Cloning into 'discord-rpc-api'... remote: Counting objects: 12, done. <br> remote: Compressing objects: 100% (12/12), done. <br> remote: Total 12 (delta 4), reused 5 (delta 0) <br> Unpacking objects: 100% (12/12), done. ==> Making package: discord-rpc-api 3.3.0-1 (Wed 06 Jun 2018 12:51:58 PM CDT) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Downloading discord-rpc-api-3.3.0.tar.gz... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 130 0 130 0 0 582 0 --:--:-- --:--:-- --:--:-- 580 100 2056k 100 2056k 0 0 3290k 0 --:--:-- --:--:-- --:--:-- 3290k ==> Validating source files with md5sums... discord-rpc-api-3.3.0.tar.gz ... Passed ==> Validating source files with sha256sums... discord-rpc-api-3.3.0.tar.gz ... Passed ==> Extracting sources... -> Extracting discord-rpc-api-3.3.0.tar.gz with bsdtar ==> Starting build()... ==> Entering fakeroot environment... ==> Starting package()... make: *** No rule to make target 'install'. Stop. ==> ERROR: A failure occurred in package(). Aborting...