Package Details: discord-overlay-git r77.51a1a0f-1

Git Clone URL: https://aur.archlinux.org/discord-overlay-git.git (read-only, click to copy)
Package Base: discord-overlay-git
Description: QT5 Overlay for discord
Upstream URL: https://github.com/trigg/DiscordOverlayLinux
Keywords: discord
Licenses: GPL3
Conflicts: discord-overlay
Provides: discord-overlay
Submitter: dangersalad
Maintainer: dangersalad
Last Packager: dangersalad
Votes: 2
Popularity: 0.84
First Submitted: 2020-05-06 15:57
Last Updated: 2020-06-03 00:36

Latest Comments

Freso commented on 2020-05-27 10:28

There’s been a change in upstream breaking this package. One of the changes is a setup.py which you will probably want to use now instead of just manually copying the binary.

dangersalad commented on 2020-05-09 00:21

@Duder963 Got it, I thought I had already added that. Also changed the deps to actual deps instead of just makedepends

@Freso Got that, thanks for the tips

Duder963 commented on 2020-05-08 18:43

Add python-pyxdg as a dependency. Trying to run the program without it results in this error

Traceback (most recent call last):

File "/usr/bin/discord-overlay", line 23, in <module>

from xdg.BaseDirectory import xdg_config_home

ModuleNotFoundError: No module named 'xdg'

Freso commented on 2020-05-08 15:17

The license is GPL3-or-later (and should be set to "GPL3"), so no need to copy that to the license collection: https://wiki.archlinux.org/index.php/PKGBUILD#license :)

dangersalad commented on 2020-05-08 14:36

@Freso, thanks for the comments, getting that cleaned up now

EDIT: I think the name change fell under "necessary changes" considering the original name was not descriptive in any way. It's a moot point now since the name changed upstream

Freso commented on 2020-05-08 09:49

Please clean up comments and unused variables in the PKGBUILD.

Also, don’t change executable names when installing (Arch Linux simplicity principle). Name has been changed upstream now (which also breaks the PKGBUILD) too, which was the right way to fix this.

Additionally, there’s a .desktop and a README that should possibly also get installed in their relevant locations.

PS. I was actually meaning to make a package for this, but I guess you beat me. :) If you want a co-maintainer, I’d be happy to help fix up this package.

Duder963 commented on 2020-05-08 09:02

Installation fails with this message

install: cannot stat '/home/duder963/discord-overlay-git/src/discord-overlay/overlay-qt5.py': No such file or directory

midget_3111 commented on 2020-05-06 17:09

Works as expected, thanks!