Package Details: diodon 1.11.0-1

Git Clone URL: https://aur.archlinux.org/diodon.git (read-only, click to copy)
Package Base: diodon
Description: GTK+ clipboard manager
Upstream URL: https://launchpad.net/diodon
Licenses: GPL
Submitter: jose1711
Maintainer: lmartinez-mirror
Last Packager: lmartinez-mirror
Votes: 11
Popularity: 0.000837
First Submitted: 2011-01-26 13:48
Last Updated: 2021-07-14 04:44

Latest Comments

1 2 3 Next › Last »

lmartinez-mirror commented on 2021-07-13 22:37

Upstream has added libayatana-appindicator as a dependency. Please let me know if this is a hard dependency, or if this can be ignored with the commented out flag.

willemw commented on 2021-07-13 21:32

Conflicts diodon-git and I think also the .install file are not necessary.

jose1711 commented on 2021-04-14 22:53

not using it anymore, up for adoption

puneet commented on 2020-03-30 08:32

can you update the libappindicator3 dependency to libappindicator-gtk3

jose1711 commented on 2019-03-04 08:34

for the record: tydynrain was able to resolve the compilation issue by temporarily switching to default Gnome theme

tydynrain commented on 2019-02-10 00:38

That is very curious indeed. I have diodon installed on three separate Arch installs, and it is failing with the same error message in each one. I can't upgrade until I can figure out what the missing dependency is.

jose1711 commented on 2019-02-09 23:25

hmm.. output on my system looks pretty much the same but it does not terminate with an error.

Setting top to                           : ../diodon/src/diodon-1.8.0 
Setting out to                           : ../diodon/src/diodon-1.8.0/_build_ 
Checking for 'c_bgxlc' (c compiler)      : not found 
Checking for 'gcc' (c compiler)          : /usr/bin/gcc 
Checking for program msgfmt              : /usr/bin/msgfmt 
Checking for program perl                : /usr/bin/perl 
Checking for 'intltool-merge'            : /usr/bin/intltool-merge 
Checking for header locale.h             : yes 
Checking for program glib-genmarshal     : /usr/bin/glib-genmarshal 
Checking for program perl                : /usr/bin/perl 
Checking for 'glib-mkenums'              : /usr/bin/glib-mkenums 
Checking for program glib-compile-schemas : /usr/bin/glib-compile-schemas 
Checking for program valac-0.30           : not found 
Checking for program valac                : /usr/bin/valac 
Checking for valac version >= (0, 30, 0)  : (0, 42, 5) 
Checking for program pkg-config           : /usr/bin/pkg-config 
Checking for 'gdk-3.0' >= 3.0.8           : yes 
Checking for 'gdk-x11-3.0' >= 3.0.8       : yes 
Checking for 'libpeas-1.0' >= 1.1.0       : yes 
Checking for 'libpeas-gtk-1.0' >= 1.1.0   : yes 
Checking for 'gio-2.0' >= 2.32.0          : yes 
Checking for 'gio-unix-2.0' >= 2.32.0     : yes 
Checking for 'glib-2.0' >= 2.32.0         : yes 
Checking for 'gtk+-3.0' >= 3.10.0         : yes 
Checking for 'xtst' >= 1.2.0              : yes 
Checking for 'zeitgeist-2.0' >= 0.9.14    : yes 
Checking for program Xvfb                 : /usr/bin/Xvfb 
Checking for 'appindicator3-0.1' >= 0.3.0 : yes 
'configure' finished successfully (0.452s)
Waf: Entering directory `../diodon/src/diodon-1.8.0/_build_'
[70/70] utest: _build_/tests/diodon-test
Waf: Leaving directory `../diodon/src/diodon-1.8.0/_build_'
execution summary 
  tests that pass 1/1 
    /home/jose/..diodon-1.8.0/_build_/tests/diodon-test 
  tests that fail 0/1 
'build' finished successfully (1.143s)

tydynrain commented on 2019-02-09 20:27

@jose1711 Sadly it does not, as that package is already installed.

jose1711 commented on 2019-02-09 16:54

@tydynrain does installing libappindicator-gtk3 sort out the issue?

tydynrain commented on 2019-02-08 23:10

Missing dependencies:

Checking for 'c_bgxlc' (c compiler) : not found

Checking for 'gcc' (c compiler) : /usr/lib/ccache/bin/gcc

Checking for program msgfmt : /usr/bin/msgfmt

Checking for program perl : /usr/bin/perl

Checking for 'intltool-merge' : /usr/bin/intltool-merge

Checking for header locale.h : yes

Checking for program glib-genmarshal : /usr/bin/glib-genmarshal

Checking for program perl : /usr/bin/perl

Checking for 'glib-mkenums' : /usr/bin/glib-mkenums

Checking for program glib-compile-schemas : /usr/bin/glib-compile-schemas

Checking for program valac-0.30 : not found

Checking for program valac : /usr/bin/valac

Checking for valac version >= (0, 30, 0) : (0, 42, 5)

Checking for program pkg-config : /usr/bin/pkg-config

Checking for 'gdk-3.0' >= 3.0.8 : yes

Checking for 'gdk-x11-3.0' >= 3.0.8 : yes

Checking for 'libpeas-1.0' >= 1.1.0 : yes

Checking for 'libpeas-gtk-1.0' >= 1.1.0 : yes

Checking for 'gio-2.0' >= 2.32.0 : yes

Checking for 'gio-unix-2.0' >= 2.32.0 : yes

Checking for 'glib-2.0' >= 2.32.0 : yes

Checking for 'gtk+-3.0' >= 3.10.0 : yes

Checking for 'xtst' >= 1.2.0 : yes

Checking for 'zeitgeist-2.0' >= 0.9.14 : yes

Checking for program Xvfb : /usr/bin/Xvfb

Checking for 'appindicator3-0.1' >= 0.3.0 : yes

execution summary

tests that pass 0/1

tests that fail 1/1