Package Details: digilent.adept.runtime 2.21.2-1

Git Clone URL: https://aur.archlinux.org/digilent.adept.runtime.git (read-only, click to copy)
Package Base: digilent.adept.runtime
Description: The Adept Runtime consists of the shared libraries, firmware images, and configuration files necessary to communicate with Digilent's devices.
Upstream URL: https://reference.digilentinc.com/reference/software/adept/start
Keywords: Adept Digilent
Licenses: custom
Submitter: cyrozap
Maintainer: cyrozap
Last Packager: cyrozap
Votes: 12
Popularity: 0.003225
First Submitted: 2015-08-10 01:54
Last Updated: 2021-02-10 03:12

Latest Comments

cyrozap commented on 2021-02-10 03:28

@okasha: I think I'm going to leave the udev rules as they are, rather than move them under /usr/lib/udev/rules.d. My reason for this is that the rules file from the original package sets the permissions for Digilent devices to 666, and a user might want to change that to be more restrictive or use TAG+="uaccess". Also, changing this now might be an annoying surprise to users that have done this.

That said, if we're going to put rules in the system udev rules directory, we should probably just not bother with the package udev rules file and replace it with our own.

okasha commented on 2021-02-08 16:24

consider this patch for updating https://github.com/okasha55/digilent.adept.runtime-aur

okasha commented on 2021-02-08 14:53

by @yjun : https://wiki.archlinux.org/index.php/Udev#Installation

udev rules written by the administrator go in /etc/udev/rules.d/, their file name has to end with .rules. The udev rules shipped with various packages are found in /usr/lib/udev/rules.d/.

maybe add udev rules to /usr/lib/udev/rules.d/ instead of /etc/udev/rules.d/ as package files

matteoipri commented on 2019-01-30 21:03

@cyrozap: Thank you!

cyrozap commented on 2019-01-30 07:20

@matteoipri, @Sc00tis_P00tis: Sorry for the delay on this--I had assumed Digilent would fix the cert in a timely manner, but I guess that didn't happen.

@matteoipri: HTTPS doesn't need a token--that link you posted actually just redirects to the HTTP version of the files.digilent.com link.

I'll push an update shortly.

matteoipri commented on 2019-01-27 22:13

Hi, first of all, thanks for the package! I found out that installing it is not possible due to the expired TLS certificate of the download link (x86_64). Downloading via plain http, from the same URL, works fine. It seems like downloading through https needs a link with a token, like this: https://reference.digilentinc.com/lib/exe/fetch.php?tok=b89d8e&media=http%3A%2F%2Ffiles.digilent.com%2FSoftware%2FAdept2%2BRuntime%2F${pkgver}%2F${pkgname}_${pkgver}-amd64.deb

Sc00tis_P00tis commented on 2019-01-19 23:48

The x86-64 link's SSL certificate has expired, which prevents curl from downloading the .deb. I solved this by downloading the snapshpot and revising the link to http.

cyrozap commented on 2016-02-02 05:12

Thanks for the heads-up! I've updated the package to use the new URLs.

KARNVORbeefRAGE commented on 2016-01-29 22:21

Thanks for the submission, unfortunately the current url does not work since the site had a revision. This url should contain all the files from before: https://reference.digilentinc.com/digilent_adept_2#bit1