Package Details: diaspora-mysql 0.7.14.0-1

Git Clone URL: https://aur.archlinux.org/diaspora-mysql.git (read-only, click to copy)
Package Base: diaspora-mysql
Description: A distributed privacy aware social network (MySQL)
Upstream URL: https://diasporafoundation.org
Licenses: AGPL3
Conflicts: diaspora-mysql-git, diaspora-postgresql, diaspora-postgresql-git
Submitter: jhass
Maintainer: jhass
Last Packager: jhass
Votes: 6
Popularity: 0.146798
First Submitted: 2016-09-05 18:58
Last Updated: 2020-06-14 21:18

Latest Comments

1 2 Next › Last »

jhass commented on 2020-06-14 21:24

Hey, I just updated the package to 0.7.14 and thus Ruby 2.6. Does this still happen for you?

agaskins commented on 2020-06-14 21:08

bundler: command not found: rake-2.5
Install missing gem executables with `bundle install`
==> ERROR: A failure occurred in build().
    Aborting...

fordprefect commented on 2020-04-24 17:29

Thanks, working with ruby2.5 now and all seems fine, bundler however needed to be downgraded to 1.7.3 (last version of the 1.x branch). Wasn't diaspora running with bundler 2.x already on ruby2.4? Sorry for so many questions…

jhass commented on 2020-04-23 16:12

Ruby 2.7 will just drown you in deprecation warnings, otherwise yes, it might.

Welp, anyways I just went ahead and updated the packages to use Ruby 2.5, let's see how that'll go...

fordprefect commented on 2020-04-22 15:42

Sounds like even the up-to-date extra/ruby (2.7.1) could be an option if run only in production? Maybe the PKGBUILD could get a _rubyver variable to easily build for a different version (I suppose that is the only thing that needs to be done switching ruby versions?)? Thanks for the very reliable work!

jhass commented on 2020-04-22 15:27

Kinda... https://github.com/diaspora/diaspora/pull/7929

Many of us are already running on 2.5 or 2.6 without issues.

fordprefect commented on 2020-04-22 14:59

@jhass: ruby2.4 still seems to be a dependency for this package, but you just deprecated that package. Any plans to update diaspora to a newer ruby version?

jhass commented on 2018-05-11 17:28

Okay, my workaround for https://bugs.archlinux.org/index.php?do=details&task_id=58414 doesn't do. I'm grateful for any ideas anybody has, otherwise we have to wait for the ecosystem to catch up, sorry.

Meanwhile you should be able to start back up with writing some systemd units that avoid eye and start unicorn and sidekiq directly.

visage commented on 2018-05-10 14:31

Version 0.7.5.0-5 builds successfully, but fails to start. I get this error in console:

Starting Diaspora in production mode with 1 Sidekiq worker(s).

/usr/share/webapps/diaspora/vendor/bundle/ruby/2.3.0/gems/eye-0.10.0/lib/eye/sigar.rb:1:in 'require': /usr/share/webapps/diaspora/vendor/bundle/ruby/2.3.0/gems/kostya-sigar-2.0.0/lib/sigar.so: undefined symbol: __rpc_createerr - /usr/share/webapps/diaspora/vendor/bundle/ruby/2.3.0/gems/kostya-sigar-2.0.0/lib/sigar.so (LoadError)
    from /usr/share/webapps/diaspora/vendor/bundle/ruby/2.3.0/gems/eye-0.10.0/lib/eye/sigar.rb:1:in '<top (required)>'
    from /usr/share/webapps/diaspora/vendor/bundle/ruby/2.3.0/gems/eye-0.10.0/lib/eye/controller.rb:11:in `require'
    from /usr/share/webapps/diaspora/vendor/bundle/ruby/2.3.0/gems/eye-0.10.0/lib/eye/controller.rb:11:in `<top (required)>'
    from /usr/share/webapps/diaspora/vendor/bundle/ruby/2.3.0/gems/eye-0.10.0/lib/eye/control.rb:2:in `require'
    from /usr/share/webapps/diaspora/vendor/bundle/ruby/2.3.0/gems/eye-0.10.0/lib/eye/control.rb:2:in `<top (required)>'
    from /usr/share/webapps/diaspora/vendor/bundle/ruby/2.3.0/gems/eye-0.10.0/bin/loader_eye:52:in `require'
    from /usr/share/webapps/diaspora/vendor/bundle/ruby/2.3.0/gems/eye-0.10.0/bin/loader_eye:52:in `<top (required)>'
    from /usr/share/webapps/diaspora/vendor/bundle/ruby/2.3.0/bin/loader_eye:22:in `load'
    from /usr/share/webapps/diaspora/vendor/bundle/ruby/2.3.0/bin/loader_eye:22:in `<main>'

jasondaigo commented on 2017-12-14 21:44

[fixed atm]fails to build for me on my desktop and server (amd64); stops at

"Fetching version metadata from https://rubygems.org/Net::HTTPNotFound"

nvm the other day all files found somehow