Package Details: dfhack 0.47.04-1

Git Clone URL: https://aur.archlinux.org/dfhack.git (read-only, click to copy)
Package Base: dfhack
Description: memory hacking library for Dwarf Fortress and a set of tools that use it
Upstream URL: https://dfhack.readthedocs.io/en/stable/
Keywords: dwarffortress
Licenses: custom
Conflicts: dfhack-bin, dfhack-git
Submitter: unknown
Maintainer: wookietreiber (albron, Ziusudra)
Last Packager: wookietreiber
Votes: 34
Popularity: 0.010147
First Submitted: 2011-08-07 11:03
Last Updated: 2020-03-14 10:20

Latest Comments

« First ‹ Previous 1 2 3 4 5

stradian commented on 2014-07-01 00:22

Pkgbuild needs updating, as dfhack is now at r5.

dpflug commented on 2014-06-19 23:45

This doesn't work with the community dwarffortress package because libgraphics.so is stripped. I've emailed the maintainer to see if he wants to do anything with it.

unknown commented on 2013-07-03 18:57

disowned due to lack of interest in dwarffortress.

Flaeme commented on 2013-04-15 20:12

As mentioned, the download location has changed, the version is outdated, and as far as I can tell, there are a few missing dependencies for stomesense; using ldd, with the LD_LIBRARY_PATH dfhack uses, on the stonesense.plugin.so, I was able to find my missing libs - namely lib32-libpng12 and a symlink from /usr/lib32/libjpeg.so.62 to /usr/lib32/libjpeg.so (as lib32-jpeg-turbo has different version numbers, but seems to be compatible - YMMV). lib32-allegro and the mentioned edit to dfhack might work, but I did not try it. Either way, this is definitely out of date.

crazedpsyc commented on 2013-03-20 15:09

New releases have been moved, since github's download feature was deprecated. They are now http://dethware.org/dfhack/download/dfhack-${pkgver}-r${pkgrel}-Linux.tar.gz
$pkgrel is up to 3 now, too.

Anonymous comment on 2013-02-02 12:38

To get stonesense to work install allegro and lib32-allegro, then change the dfhack script to set the ld lookup dir to this, and make sure /opt/df_linux is owned by root:games

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:"./hack

cheesinglee commented on 2012-07-07 15:29

New PKGBUILD for 0.34.11-r1. Replaced dwarffortress-mayday dependency with plain dwarffortress.

http://pastebin.com/d4fM3zjr

unknown commented on 2011-08-07 11:04

In case of troubles, use dfhack-git.
This package is known to work for only a handful of people.