Package Details: desktop-dimmer 4.0.4-2

Git Clone URL: https://aur.archlinux.org/desktop-dimmer.git (read-only, click to copy)
Package Base: desktop-dimmer
Description: Enables darker-than-dark Desktop dimming for your displays.
Upstream URL: https://github.com/sidneys/desktop-dimmer
Licenses: Custom:CC0-1.0
Submitter: ademayo
Maintainer: jgwak
Last Packager: jgwak
Votes: 4
Popularity: 0.001246
First Submitted: 2017-02-14 18:27
Last Updated: 2019-11-18 20:01

Latest Comments

jgwak commented on 2020-02-04 12:28

@dezigner Again, it works on older pango. That's why it still works on other distros out of box. If you are capable of building this package on latest Arch and willing to maintain this package, give me the working PKGBUILD and you will be the maintainer.

dezigner commented on 2020-02-04 12:12

This application works perfectly in Ubuntu, and is also ported to rpm via Alien without any questions. Perhaps this program can also work in Arch.

I use it daily in OpenSuse 15.1.

http://packages.elementary.io/appcenter/pool/main/c/com.github.panosx2.brightness/

jgwak commented on 2020-02-03 16:47

Unfortunately, this package is abandoned by upstream developer. I have tried couple patches on the github issue and pull requests however I couldn't build this package to work on the latest Arch. The only working solution I could get to work is to partially downgrade pango to older version. If anyone managed to build this package to work on latest Arch and is willing to maintain this package, please let me know.

dezigner commented on 2020-02-03 07:07

$ desktop-dimmer

(desktop-dimmer:29826): Pango-ERROR **: 12:06:49.968: Harfbuzz version too old (1.2.7)

yochananmarqos commented on 2018-09-13 19:37

You did not include the dependencies: libxtst gtk2 gconf libxss alsa-lib

Also, the license is CC0 1.0 Universal, not MIT.

coderobe commented on 2018-01-19 08:49

currently, this PKGBUILD doesn't build because it's trying to do parameter expansion in single-quoted strings