Package Details: deoplete-git r1885.d52c297-1

Git Clone URL: https://aur.archlinux.org/deoplete-git.git (read-only, click to copy)
Package Base: deoplete-git
Description: deoplete completion plugin for neovim
Upstream URL: https://github.com/Shougo/deoplete.nvim
Licenses: MIT
Conflicts: deoplete
Provides: deoplete
Submitter: Trent
Maintainer: Trent
Last Packager: Trent
Votes: 0
Popularity: 0.000000
First Submitted: 2018-01-02 10:21
Last Updated: 2020-05-31 15:12

Dependencies (6)

Required by (2)

Sources (1)

Latest Comments

Freso commented on 2020-05-13 10:09

Hi. You don’t need to update the PKGBUILD with simple version bumps. The pkgver() will do that automatically for whomever builds it at the time of building.

Trent commented on 2020-03-13 01:30

update no longer requires python-msgpack>=1.0.0

Trent commented on 2020-02-20 00:09

dependency added for python-msgpack>=1.0.0, which as of Feb 19, is not available as an Arch Package, relevant github issues deoplete issue 1072 deoplete issue 1071

One solution is to switch from deoplete-git to deoplete.

It's also trivial to upgrade python-msgpack by building an Arch Package. You can see the current PKGBUILD. So then to build i.e. just the python3 version, you would edit the version number, edit the md5sum, and strip out the python2-specific build instructions and you would end up with a PKGBUILD like this. And then cd to the directory where you have your PKGBUILD and makepkg -si to build and install.