Package Details: deluge-git 1:2.0.4.dev23.g2f1c008a2-1

Git Clone URL: https://aur.archlinux.org/deluge-git.git (read-only, click to copy)
Package Base: deluge-git
Description: A BitTorrent client with multiple user interfaces in a client/server model (git version, 'develop' branch)
Upstream URL: https://deluge-torrent.org/
Keywords: bittorrent p2p torrent
Licenses: GPL3
Conflicts: deluge
Provides: deluge
Submitter: None
Maintainer: dbermond
Last Packager: dbermond
Votes: 94
Popularity: 0.004098
First Submitted: 2010-03-19 14:12
Last Updated: 2020-04-01 12:33

Dependencies (38)

Required by (20)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

Anonymous comment on 2012-10-20 21:55

I can't get the daemon to start in deluge-web :/
If I start it before it doesnt't change anything, I get this:


Traceback (most recent call last):
File "/usr/lib/python2.7/logging/__init__.py", line 846, in emit
msg = self.format(record)
File "/usr/lib/python2.7/logging/__init__.py", line 723, in format
return fmt.format(record)
File "/usr/lib/python2.7/logging/__init__.py", line 464, in format
record.message = record.getMessage()
File "/usr/lib/python2.7/logging/__init__.py", line 324, in getMessage
msg = str(self.msg)
File "/usr/lib/python2.7/site-packages/deluge/error.py", line 47, in __str__
return self.message
File "/usr/lib/python2.7/site-packages/deluge/error.py", line 40, in _get_message
return self._message
AttributeError: 'DaemonRunningError' object has no attribute '_message'
Logged from file main.py, line 263
23:54:32.065 [ERROR ][deluge.main :264 ] You cannot run multiple daemons with the same config directory set.
23:54:32.066 [ERROR ][deluge.main :265 ] If you believe this is an error, you can force a start by deleting /home/guigui/.config/deluge/deluged.pid.

Anonymous comment on 2012-10-20 08:04

updated according to your suggestions. Please report any issues

foolosophy commented on 2012-10-19 21:36

The "storage move" bug was already fixed upstream. ishanarora's patch is superfluous
http://dev.deluge-torrent.org/ticket/2140

CtHx commented on 2012-10-13 21:57

Master branch seems not work correctly, I can't connect to the server from the web interface.
Changing to 1.3-stable branch solved my problem.

In initscripts deluge is locked to "deluge" user, maybe it's better to put $DELUGE_USER and put
"deluge" in /etc/conf.d/deluged (DELUGE_USER="deluge")

Anonymous comment on 2012-10-13 05:44

updated with latest changes of extra's\PKGBUILD (systemd stuff) and applied patch by ishanarora - please test the PKGBUILD and report any issues ! thanks

ishanarora commented on 2012-10-04 02:46

Move on completion is broken in deluge and deluge-git. The following patch solves it: https://bugs.archlinux.org/task/29414?getfile=9215

CtHx commented on 2012-09-27 15:40

Does the lates version work? I see in the web-interface the server offline...

jackoneill commented on 2012-09-06 05:40

It's python2-mako. It's even listen in the optdepends.

Anonymous comment on 2012-09-05 15:43

I just installed it using makepkg, but I get this:
[root@host ~]# /etc/rc.d/deluge
deluge-web deluged
[root@host ~]# /etc/rc.d/deluge-web start
:: Starting Deluge WebUI [BUSY] /usr/lib/python2.7/site-packages/deluge/ui/web/common.py:83: RuntimeWarning: The Mako library is required to run deluge.ui.web
RuntimeWarning)
[DONE]
and python-mako (0.7.2-1) was installed.
Then when I browse to the site, it returns this error: web.Server Traceback (most recent call last):
exceptions.RuntimeError: The Mako library is required to run deluge.ui.web

Anonymous comment on 2012-07-14 17:20

just tried the PKGBUILD, no problems with it (try manual makepkg)