Package Details: deluge-git 1:2.0.0b2.dev313.gb2e19561e-2

Git Clone URL: https://aur.archlinux.org/deluge-git.git (read-only)
Package Base: deluge-git
Description: A BitTorrent client with multiple user interfaces in a client/server model (git version, 'develop' branch)
Upstream URL: https://deluge-torrent.org/
Keywords: bittorrent p2p torrent
Licenses: GPL3
Conflicts: deluge
Provides: deluge
Submitter: None
Maintainer: dbermond
Last Packager: dbermond
Votes: 92
Popularity: 0.024276
First Submitted: 2010-03-19 14:12
Last Updated: 2019-01-22 14:50

Required by (18)

Sources (3)

Latest Comments

1 2 3 4 5 6 Next › Last »

dbermond commented on 2019-01-22 14:52

@lcts Thank you for pointing this. I already have python2-gobject installed and was not noticing this missing dependency. Fixed

lcts commented on 2019-01-19 09:36

It appears that the GTK UI now depends on python2-gobject, but pygtk only pulls in python2-gobject2 (i.e. the legacy version). Seems weird to me, and I haven't done further testing, but if you're using the GTK UI, and deluge fails to start with this error:

Traceback (most recent call last):

File "/usr/bin/deluge", line 11, in <module> load_entry_point('deluge==2.0.0b2.dev313', 'gui_scripts', 'deluge')()

File "/usr/lib/python2.7/site-packages/deluge/ui/ui_entry.py", line 143, in start_ui ui.start()

File "/usr/lib/python2.7/site-packages/deluge/ui/gtk3/init.py", line 43, in start from .gtkui import GtkUI

File "/usr/lib/python2.7/site-packages/deluge/ui/gtk3/gtkui.py", line 19, in <module> import gi # isort:skip (Required before Gtk import).

ImportError: No module named gi

then you can fix it by installing python2-gobject.

dbermond commented on 2018-12-04 15:02

@lcts Thank you for pointing this. Fixed. A recent upstream commit introduced the need for python2-rencode dependency:

https://github.com/deluge-torrent/deluge/commit/e7127637cf87a7f08723641ae253e8330a59c0bd

dbermond commented on 2017-07-15 21:17

I have changed permissions of directory '/srv/deluge'. Before upgrading the package, please run the following command to avoid a pacman warning:
# chmod 775 /srv/deluge

If you have already upgraded the package before seeing this notice, you should have received the following pacman warning:
warning: directory permissions differ on /srv/deluge/
filesystem: 664 package: 775

This is a harmless warning. Just execute the mentioned chmod command to fix directory permissions and avoid this warning on the next upgrades.

The last package update also fixed problems with the deluge systemd services. They are now working fine.

dbermond commented on 2017-05-13 15:41

libtorrent-rasterbar 1.1.2 is not required anymore.
libtorrent-rasterbar 1.1.3 is now on binary repositories and and deluge-git seems to be working fine with it.

dbermond commented on 2017-04-09 18:38

deluge-git currently has an upstream requirement of a specific libtorrent-rasterbar version, which is 1.1.2. It will not work with libtorrent-rasterbar 1.1.1 or the current libtorrent-rasterbar git master.
But the libtorrent-rasterbar version offered in the binary repositories is currently outdated, being at 1.1.1.

Being such, you have 3 options if you want to build and use deluge-git:

1) use libtorrent-rasterbar-git 1.1.2.r0.ga42d4390c, which is the default PKGBUILD method. This is the same as libtorrent-rasterbar 1.1.2, but using the git repository.
For this you will need to manually modify libtorrent-rasterbar-git PKGBUILD in order to obtain this specific version: append '#commit=a42d4390c' at the source line (currently there is a ready to use source line for achieving this in libtorrent-rasterbar-git PKGBUILD).
2) use libtorrent-rasterbar 1.1.2. For this you will need to use the PKGBDUILD from the binary repository and modify it to get version 1.1.2.
3) wait for the release of libtorrent-rasterbar 1.1.2 in binary repositories.

dbermond commented on 2017-04-09 18:37

I've adopted this package and putted it to work again.
Please see the important note about libtorrent-rasterbar dependency in the pinned post.
Have a happy deluging! :)

borrelnoot commented on 2017-02-14 22:38

==> Starting build()...
running build
running build_webui
Import error: Requires "slimit" package for minifying WebUI files.

The slimit PKGBUILD needs to be updated aswell.

skydrome commented on 2016-06-30 22:37

added it to makedeps, thanks
hmm, i thought it would minify them itself, ill look into it, never used the webui myself which is why i never came across that

NStal commented on 2016-06-30 06:13

We should run `python2 minify_web_js.py ` before install or the webUI will show blank page.

And to make webUI work corrently, we should also downgrade libtorrent to <=1.0.9 :(