Package Details: debhelpergit 13.2.1-1

Git Clone URL: https://aur.archlinux.org/debhelpergit.git (read-only, click to copy)
Package Base: debhelpergit
Description: A collection of programs that can be used in a debian/rules file to automate common tasks
Upstream URL: https://salsa.debian.org/debian/debhelper.git/
Licenses: GPL2, GPL3
Provides: debhelper
Submitter: linuxergr
Maintainer: linuxergr
Last Packager: linuxergr
Votes: 0
Popularity: 0.000000
First Submitted: 2020-02-24 09:09
Last Updated: 2020-09-18 08:53

Dependencies (13)

Required by (10)

Sources (1)

Latest Comments

linuxergr commented on 2020-08-27 08:50

Done, reinstall the package

Kzer-Za commented on 2020-08-27 06:08

Could you add provides=('debhelper') to the PKGBUILD? I have debhelpergit installed, but when I try to install simple-fb2-reader it still wants to install debhelper.

linuxergr commented on 2020-07-01 22:34

The package debhelper exists too, which is more or less the same base as a package.

I started packaging, in order to provide the most recent release, and by mistype, I forgot to add the -, at the repo name.

As you mentioned, I just added the dependency as a regular one.

You are right, it has been added as a make one.

Regards

SuperBoby commented on 2020-07-01 22:02

Thanks. I see that you included it as a regular dependency, are you sure that it's not just needed as a build dependency ?

Also, just out of curiosity, shouldn't this package be named debhelper-git ?

linuxergr commented on 2020-07-01 12:28

Hi and thanks for the feedback.

Something was probably changed to the previous packages' dependencies, or this one was not added to them.

Anyway, the PKGBUILD has been corrected to include it.

SuperBoby commented on 2020-07-01 11:14

Hi, I encountered a build error caused by a missing dependency.

I had to install perl-pod-parser because I was getting this error :

==> Starting build()...
po4a --previous -L UTF-8 man/po4a/po4a.cfg
printf "package Debian::Debhelper::Dh_Version;\n\$version='13';\n1" > \
        lib/Debian/Debhelper/Dh_Version.pm
Unknown format type: pod.
List of valid formats:
  - asciidoc: AsciiDoc format.
  - dia: uncompressed Dia diagrams.
  - docbook: DocBook XML.
  - guide: Gentoo Linux's XML documentation format.
  - ini: INI format.
  - kernelhelp: Help messages of each kernel compilation option.
  - latex: LaTeX format.
  - man: Good old manual page format.
  - pod: Perl Online Documentation format.
  - rubydoc: Ruby Documentation (RD) format.
  - sgml: either DebianDoc or DocBook DTD.
  - texinfo: The info page format.
  - tex: generic TeX documents (see also latex).
  - text: simple text document.
  - wml: WML documents.
  - xhtml: XHTML documents.
  - xml: generic XML documents (see also docbook).
  - yaml: YAML documents.
make: *** [Makefile:72: po4a-stamp] Error 1
==> ERROR: A failure occurred in build().
    Aborting...
error making: %!s(func() string=0x555685aeae80)