Package Details: deadbeef-git r9681.35714bfc7-1

Git Clone URL: https://aur.archlinux.org/deadbeef-git.git (read-only, click to copy)
Package Base: deadbeef-git
Description: A GTK+ audio player for GNU/Linux (devel branch)
Upstream URL: https://deadbeef.sourceforge.io/
Licenses: GPL2, zlib, LGPL2.1
Conflicts: deadbeef
Provides: deadbeef
Submitter: archtux
Maintainer: ToadKing
Last Packager: ToadKing
Votes: 106
Popularity: 1.01
First Submitted: 2009-08-21 13:16
Last Updated: 2020-09-26 13:58

Dependencies (54)

Required by (42)

Sources (1)

Latest Comments

1 2 3 4 5 6 Next › Last »

ToadKing commented on 2021-02-06 16:35

soloturn: I think that should be fixed in your package by marking it as providing libblocksruntime.

soloturn commented on 2021-02-06 10:15

updated libdispatch-git to newest now, providing both libblocksruntime and libdispatch.

ToadKing commented on 2020-09-19 18:05

New changes from upstream now require clang to build and require libblocksruntime and libdispatch at runtime. Currently only the last.fm and notify plugins actually require these but the upstream dev is working on moving more plugins and core parts of deadbeef to also require them in the future, so they're hard dependencies.

ToadKing commented on 2020-07-10 13:16

DanEng1982, it still builds fine here. What compile errors are you getting, and are you building from a clean repo?

DanEng1982 commented on 2020-07-10 12:04

Dead yes, beefy not so much anymore. Broken, doesn't compile since two weeks or so on ArchDeepin.

ToadKing commented on 2020-07-05 17:06

I've adopted the package. Build should be fixed and added opusfile as an optional dependency. If you're using an AUR helper like yay make sure you do a clean build.

Soukyuu commented on 2020-07-05 11:54

I am not really using deadbeef anymore, so I disowned the package. Feel free to adopt.

zhqrbitee commented on 2020-07-03 22:02

It seems deadbeef has included new submodule 'external/mp4p' , so need to add 'git submodule init; git submodule update' in prepare function to sync everything, otherwise compile will fail.

laichiaheng commented on 2019-09-22 16:42

It becomes gtk2 only.

OS: Manjaro Unstable Branch.

argo commented on 2019-06-02 00:57

Would not hurt to have "opusfile" in optdepends too since it's required for opus playback plugin.