Package Details: davinci-resolve-beta 16.1b3-2

Git Clone URL: https://aur.archlinux.org/davinci-resolve-beta.git (read-only, click to copy)
Package Base: davinci-resolve-beta
Description: Professional A/V post-production software suite from Blackmagic Design
Upstream URL: https://www.blackmagicdesign.com/support/family/davinci-resolve-and-fusion
Licenses: Commercial
Conflicts: davinci-resolve, davinci-resolve-studio, davinci-resolve-studio-beta
Provides: davinci-resolve
Submitter: satriani
Maintainer: satriani (Ashark)
Last Packager: Ashark
Votes: 14
Popularity: 0.42
First Submitted: 2017-05-04 16:50
Last Updated: 2019-09-26 20:51

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

satriani commented on 2017-07-05 15:11

Hey, Antergos is my favorite distribution. I use Antergos as well :)

[quote=jasperlevi]
will it install the necessary libs and NVidia+CUDA drivers required to run it automatically if I install from Pamac?
[/quote]

You must install one of opencl-driver on your machine. In my opinion you need to install opencl-nvidia. Take a look here: https://wiki.archlinux.org/index.php/GPGPU#NVIDIA

Good luck.

jasperlevi commented on 2017-07-05 12:39

Hi Guys, I'm a complete newbie here, having moved over from Ubuntu Gnome. I had Resolve 14b4 working on Ubuntu after having followed the guide from https://forum.blackmagicdesign.com/viewtopic.php?f=21&t=58668. Unfortunately, I have not been able to get it going on Antergos. I tried to install it earlier, by downloading the zip archive from the BMD site, and other stuff. It did install but would not launch, probably because dependencies were not met.

I can also see a method to install it using Pamac, which is linked to this page. It lists the dependencies required to install Resolve 14b4. My question is - will it install the necessary libs and NVidia+CUDA drivers required to run it automatically if I install from Pamac?

My computer has a Nvidia GTX 960 with 4GB of VRAM, along with 32 GB of RAM and an i7 5820K for the processor.

satriani commented on 2017-07-05 08:10

Hello unimatrixdoc,
You have an old package 14.0b3 but you need 14.0b4 :)
Just download a new package here https://www.blackmagicdesign.com/products/davinciresolve/
Make sure the file is in the correct folder /tmp/yaourt-tmp-doc/aur-davinci-resolve-beta or just put/leave it in a /home/$USER/Downloads

unimatrixdoc commented on 2017-07-04 23:02

Hello Satriani, ty for setting this up. I am following your directions on the previous comment: "satriani commented on 2017-06-06 16:16" and it is not successful. Here is the output of those commands with a directory listing afterwards:

.
.
.
==> Continue building davinci-resolve-beta ? [Y/n]
==> ----------------------------------------------
==> y

==> Building and installing package
-> Please remember to put a package archive DaVinci_Resolve_14.0b4_Linux.zip in to
==> Making package: davinci-resolve-beta 14.0b4-3 (Tue Jul 4 15:56:28 PDT 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
==> ERROR: DaVinci_Resolve_14.0b4_Linux.zip was not found in the build directory and is not a URL.
==> ERROR: Makepkg was unable to build davinci-resolve-beta.
==> Restart building davinci-resolve-beta ? [y/N]
==> ---------------------------------------------
==> n

[doc@hostname ARCHLINUX]$ ls -laR /tmp/yaourt-tmp-doc/
/tmp/yaourt-tmp-doc/:
total 0
drwxr-xr-x 3 doc doc 60 Jul 4 15:56 .
drwxrwxrwt 15 root root 420 Jul 4 15:56 ..
drwxr-xr-x 3 doc doc 120 Jul 4 15:56 aur-davinci-resolve-beta

/tmp/yaourt-tmp-doc/aur-davinci-resolve-beta:
total 12
drwxr-xr-x 3 doc doc 120 Jul 4 15:56 .
drwxr-xr-x 3 doc doc 60 Jul 4 15:56 ..
lrwxrwxrwx 1 doc doc 52 Jul 4 15:56 DaVinci_Resolve_14.0b3_Linux.zip -> /mnt/sdb1/Downloads/DaVinci_Resolve_14.0b3_Linux.zip
-rw-r--r-- 1 doc doc 5482 Jun 27 10:39 PKGBUILD
drwxr-xr-x 2 doc doc 40 Jul 4 15:56 src
-rw-r--r-- 1 doc doc 699 Jun 27 10:39 .SRCINFO

/tmp/yaourt-tmp-doc/aur-davinci-resolve-beta/src:
total 0
drwxr-xr-x 2 doc doc 40 Jul 4 15:56 .
drwxr-xr-x 3 doc doc 120 Jul 4 15:56 ..


[doc@hostname ARCHLINUX]$ ls -la /mnt/sdb1/Downloads/DaVinci_Resolve_14.0b3_Linux.zip
-rw-r--r-- 1 doc doc 445839823 Jun 14 20:22 /mnt/sdb1/Downloads/DaVinci_Resolve_14.0b3_Linux.zip

kalimerox commented on 2017-06-07 07:48

Thank you satriani! I could intall it! And as you pointed out , I get the same error messages as the guy in the intel video ;(

seems my gpu is just a bit too old (in my laptop, and of wrong brand in my desktop ;( )..

satriani commented on 2017-06-06 23:16

1) yaourt -S davinci-resolve-beta
2) when you're asked to edit PKGBUILD open a new terminal window and enter following (eg. the zip file is located in /home/kalimerox/Downloads)
ln -s ~/Downloads/DaVinci_Resolve_14.0b3_Linux.zip /tmp/yaourt-tmp-$USER/aur-davinci-resolve-beta
3) then go back to the first terminal and answer with no and continue the installation
that's it

Unfortunately, your GPU is not suitable for DavinciResolve :(
DavinciResolve works only from Intel Iris Graphics. Watch this video https://www.youtube.com/watch?v=G1zGXjGTpis

kalimerox commented on 2017-06-06 00:51

I managed to install the dependencies, I had to update the mirrors, that i had just only synched before.. the new trouble was:

Retrieving sources...
==> ERROR: DaVinci_Resolve_14.0b3_Linux.zip was not found in the build directory and is not a URL.


as from the other comments here i put the resolve.zip into /opt/resolve but maybe i have to do something additional to that?

PS: i got help on the manjaro forum from lolix:
Use the command:

yaourt -G davinci-resolve-beta

this will create a folder called 'davinci-resolve-beta' with a build instructions file inside, which is called PKGBUILD

put 'DaVinci_Resolve_14.0b3_Linux.zip' inside that folder

from terminal change to that directory

cd davinci-resolve-beta

build, install and clean with:

makepkg -sci




this worked for installing . later i have a segmentation fault running resolve but this might not be installation related...

kalimerox commented on 2017-06-05 14:03

@ satriani it is this one:

lspci -vnn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])


I have a saffire amd rx480 on another machine,
would that be more promising maybe?

satriani commented on 2017-06-05 10:47

kalimerox, what graphics card do you have?
Post an output of 'lspci -vnn | grep VGA'

kalimerox commented on 2017-06-05 10:25

I got this when i try to install,

warning: cannot resolve "llvm", a dependency of "beignet"
warning: cannot resolve "opencl-headers", a dependency of "beignet"
:: The following package cannot be upgraded due to unresolvable dependencies:
beignet


any idea how i can resolve these depenendcies? I m on Manjaro 64it