Package Details: dasher 5.0.0.alpha+24+gb0a3e18-1

Git Clone URL: https://aur.archlinux.org/dasher.git (read-only)
Package Base: dasher
Description: Information-efficient text-entry interface, driven by natural continuous pointing gestures
Upstream URL: http://www.gnome.org
Licenses: GPL
Submitter: htesligte
Maintainer: htesligte
Last Packager: htesligte
Votes: 4
Popularity: 0.001534
First Submitted: 2016-07-31 20:28
Last Updated: 2016-07-31 20:35

Latest Comments

xlegs commented on 2018-10-28 23:39

I cannot install due to:

==> Building and installing package
==> Making package: dasher 5.0.0.alpha+24+gb0a3e18-1 (Sun 28 Oct 2018 04:37:41 PM PDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Cloning dasher git repo...
Cloning into bare repository '/tmp/yaourt-tmp-stefan/aur-dasher/dasher'...
fatal: unable to connect to git.gnome.org:
git.gnome.org[0: 209.132.180.168]: errno=No route to host
git.gnome.org[1: 209.132.180.180]: errno=No route to host

I use dasher daily, so any help will be appreciated.

dreieck commented on 2018-08-07 12:54

Another note:

gnome-autogen.sh spills out some warnings, which might evolve to build failures in the future:

==> Starting prepare()...
/sbin/gnome-autogen.sh
***Warning*** USE_COMMON_DOC_BUILD is deprecated, you may remove it from autogen.sh
***Warning*** USE_GNOME2_MACROS is deprecated, you may remove it from autogen.sh
***Warning*** PKG_NAME is deprecated, you may remove it from autogen.sh

dreieck commented on 2018-08-07 12:53

A note: /usr/share/glib-2.0/schemas/dasher.gschema.xml makes some complications:

:: Running post-transaction hooks...
(1/3) Compiling GSettings XML schema files...
/usr/share/glib-2.0/schemas/dasher.gschema.xml:4:1  Error on line 4 char 1: Invalid name “DrawMouseLine”: names must begin with a lowercase letter.  This entire file has been ignored.

There are more entries whose names begin uppercase.

I don't know if just renaming it lowercase is OK or if it breaks other things ...

dreieck commented on 2018-08-07 12:50

Please prepend the source-entry with git+.

dreieck commented on 2018-08-07 12:45

Please set the actual version number, since you check out a specific git commit. Put your pkgver in the AUR does not reflect the pkgver that will be computed after checkout.

Please set pkgver=5.0.0.alpha+24+gb0a3e180, or anything newer if you decide to upgrade your package to any newer version.