Package Details: darkice 1.4-1

Git Clone URL: https://aur.archlinux.org/darkice.git (read-only, click to copy)
Package Base: darkice
Description: Live audio streamer. Reads from audio interface, encodes, sends to streaming server.
Upstream URL: http://www.darkice.org/
Keywords: icecast streaming
Licenses: GPL
Submitter: ilpianista
Maintainer: SpotlightKid
Last Packager: SpotlightKid
Votes: 21
Popularity: 0.044037
First Submitted: 2011-11-14 22:35
Last Updated: 2020-04-16 23:33

Pinned Comments

SpotlightKid commented on 2020-04-16 23:40

@all Heads up: I've updated the package to 1.4 and made the following changes:

  • Changed source to source distribution archive from https://github.com/rafael2k/darkice, i.e. the software is not built from a git checkout anymore.
  • Removed aacplus support, since the license status of libaacplus is problematic.

N.B.: Upstream version 1.4 is not listed on the project's web site, but it is tagged in their git repository (see https://github.com/rafael2k/darkice/issues/157).

Latest Comments

1 2 3 Next › Last »

SpotlightKid commented on 2020-04-16 23:40

@all Heads up: I've updated the package to 1.4 and made the following changes:

  • Changed source to source distribution archive from https://github.com/rafael2k/darkice, i.e. the software is not built from a git checkout anymore.
  • Removed aacplus support, since the license status of libaacplus is problematic.

N.B.: Upstream version 1.4 is not listed on the project's web site, but it is tagged in their git repository (see https://github.com/rafael2k/darkice/issues/157).

Refutationalist commented on 2020-04-16 21:34

@SpotlightKid: I've disowned the package. Have at it, and thank you!

SpotlightKid commented on 2020-04-16 17:57

@Refutationalist: I've now tested my updated package on a several computers, including a Raspi 4 and it seems to work fine.

Can you add me as co-maintainer or orphan the package then I'll take over and update it?

SpotlightKid commented on 2020-04-08 17:47

@Refutationalist: Thanks for the offer. Let me test my package update on few more systems (e.g. a Raspi 3 and 4), before I commit to taking maintainership. I'll get back to you.

Refutationalist commented on 2020-04-08 17:00

@SpotlightKid -- Reasons. They're in here somewhere. Package tracked release until there were some problems with release. I've been checking the website for a new release now and again.

Would you like to take over the package? I stopped using darkice some time ago in favor of other methods.

SpotlightKid commented on 2020-04-08 14:04

May I ask, why this package is not using the official upstream repository (https://github.com/rafael2k/darkice) and builds from a git checkout rather than from a source distribution archive?

The repo used in this PKGBUILD is outdated, the official repo has a more recent release 1.4 (unfortunately the website hasn't been updated to show this release).

Furthermore, I would suggest to drop the inclusion of HE-AAC+ support via libaacplus. That package downloads additional patented code from 3gpp.org during the build process (!) and as such, IMO, is not suitable for distribution.

To sum it up, I suggest the following changes:

diff --git a/.SRCINFO b/.SRCINFO
index 98b30e2..721067a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
 pkgbase = darkice
    pkgdesc = Live audio streamer. Reads from audio interface, encodes, sends to streaming server.
-   pkgver = 1.3
-   pkgrel = 2
+   pkgver = 1.4
+   pkgrel = 1
    url = http://www.darkice.org/
    arch = i686
    arch = x86_64
@@ -11,16 +11,15 @@ pkgbase = darkice
    depends = lame
    depends = libpulse
    depends = faac
-   depends = libaacplus
    depends = jack
    depends = twolame
    depends = opus
    depends = libsamplerate
    depends = fftw
-   source = darkice::git+https://github.com/Ouack23/darkice.git#branch=master
+   source = https://github.com/rafael2k/darkice/releases/download/v1.4/darkice-1.4.tar.gz
    source = service
-   md5sums = SKIP
-   md5sums = 1c1cde0a5c03a2190a48275c03016eb8
+   sha256sums = e6a8ec2b447cf5b4ffaf9b62700502b6bdacebf00b476f4e9bf9f9fe1e3dd817
+   sha256sums = c5d05b1c3c352eda9591064f041fcd502d3b0a4cfcc6319dc4ae9b6d71136e4b

 pkgname = darkice

diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..ce1e253
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+darkice-*.pkg.tar.xz
+darkice-*.pkg.tar.zst
+darkice-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index a3f9a7b..a60a398 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,40 +3,47 @@
 # Contributor: Ganjolinux aka Basalari David <ganjolinux@gmail.com>
 # Contributor: speps <speps at aur dot archlinux dot org>
 # Contributor: B3l3tte <ouack23 at yahoo.fr>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot de>

 pkgname=darkice
-pkgver=1.3
-pkgrel=2
+pkgver=1.4
+pkgrel=1
 pkgdesc="Live audio streamer. Reads from audio interface, encodes, sends to streaming server."
 arch=('i686' 'x86_64' 'armv6h' 'armv7h')
 url="http://www.darkice.org/"
 license=('GPL')
-depends=('lame' 'libpulse' 'faac' 'libaacplus' 'jack' 'twolame' 'opus' 'libsamplerate' 'fftw')
-source=('darkice::git+https://github.com/Ouack23/darkice.git#branch=master'  'service')
-md5sums=('SKIP' '1c1cde0a5c03a2190a48275c03016eb8')
+depends=('lame' 'libpulse' 'faac' 'jack' 'twolame' 'opus' 'libsamplerate' 'fftw')
+source=("https://github.com/rafael2k/darkice/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
+        'service')
+sha256sums=('e6a8ec2b447cf5b4ffaf9b62700502b6bdacebf00b476f4e9bf9f9fe1e3dd817'
+            'c5d05b1c3c352eda9591064f041fcd502d3b0a4cfcc6319dc4ae9b6d71136e4b')

-build() {
-
-  cd "$srcdir/$pkgname/$pkgname/trunk"
-
-  ./autogen.sh

-  ./configure --prefix=/usr \
-              --sysconfdir=/etc \
-              --with-aacplus \
-         --with-opus \
-         --with-samplerate
+build() {
+  cd "$srcdir/$pkgname-$pkgver"
+
+  ./configure \
+    --prefix=/usr \
+    --sysconfdir=/etc \
+    --with-alsa \
+    --with-faac \
+    --with-jack \
+    --with-lame \
+    --with-opus \
+    --with-twolame \
+    --without-aacplus \
+    --with-pulseaudio \
+    --with-samplerate
   make
 }

 package() {
-  cd "$srcdir/$pkgname/$pkgname/trunk"
+  cd "$srcdir/$pkgname-$pkgver"

   make DESTDIR="$pkgdir/" install
-
-  # daemon
-  install -Dm755 "$srcdir/service" "$pkgdir/usr/lib/systemd/system/darkice@.service"
-
-  mkdir -p "$pkgdir/etc/darkice"
-  mv "$pkgdir/etc/darkice.cfg" "$pkgdir/etc/darkice/darkice.cfg"
+  # systemd service
+  install -Dm644 "$srcdir/service" "$pkgdir/usr/lib/systemd/system/darkice@.service"
+  # configuration
+  install -dm755 "$pkgdir/etc/darkice"
+  mv "$pkgdir/etc/darkice.cfg" "$pkgdir/etc/darkice"
 }

Dark-Sky commented on 2018-12-30 13:24

I had been fighting the issue on 2 arm devices (raspberry pi3b+ & odroid-xu4) trying to start the service and finally tried it on my desktop and it worked just fine. I have no clue so far why the service will not start on my arm devices. The only way so far is to manually start darkice from a terminal after logging into the desktop. The service still not start even after logging in to the desktop in a terminal. I have the latest arch installed on my desktop and arm devices.

Refutationalist commented on 2018-12-29 04:35

Create a config file with a unique name in /etc/darkice that ends in cfg and then use that name.

For example if you have a stream called "stream128", you'd create "/etc/darkice/stream128.cfg" and then issue "systemctl start darkice@stream128".

Dark-Sky commented on 2018-12-28 20:23

How do you start the service? darkice@WHAT.service

bluntroller commented on 2018-11-01 21:39

Correction. Works like expected, compiles clean.

Hint: don't mix up your setup by switching between ALSA and pulse. Work with this server/streamer for years. Cheers