Package Details: cvechecker 4.0-0

Git Clone URL: https://aur.archlinux.org/cvechecker.git (read-only, click to copy)
Package Base: cvechecker
Description: a local CVE checker tool
Upstream URL: https://github.com/sjvermeu/cvechecker
Licenses: GPL
Groups: system
Conflicts: cvechecker-svn
Provides: cvechecker
Submitter: fcolista
Maintainer: fcolista
Last Packager: fcolista
Votes: 5
Popularity: 0.000003
First Submitted: 2013-02-05 21:51
Last Updated: 2020-10-05 09:08

Latest Comments

cyveris commented on 2021-02-25 14:10

That may have been true at some prior time, but that does not appear to be the case now.

# cvechecker
cvechecker: error while loading shared libraries: libbsd.so.0: cannot open shared object file: No such file or directory
# pacman -Syu libbsd
[snip]
Packages (1) libbsd-0.10.0-2

Total Installed Size:  0.33 MiB

:: Proceed with installation? [Y/n] y
[snip]
# cvechecker
Usage: cvechecker [-CdDHirsS] [-b binlist] [-c cvefile] [-f binfile]
            [-l datafile] [-w watchlist] [--binlist=binlist]
            [--cvedata=cvefile] [--csvoutput] [--deltaonly] [--deletedeltaonly]
            [--fileinfo=binfile] [--reporthigher] [--initdbs]
            [--loaddata=datafile] [--runcheck] [--showinstalled]
            [--showinstalledfiles] [--watchlist=watchlist]

fcolista commented on 2021-01-25 09:15

@foxide can you elaborate the reason? libbsd is needed only at compile time, not at runtime to make it work. Thanks.

cyveris commented on 2021-01-25 01:19

libbsd needs to be changed to a dependency, not a makedep

fcolista commented on 2018-12-04 07:30

Upgraded to 3.9. CVEChecker needed autoconf to build.

Plexcon commented on 2018-01-11 00:54

config.status: error: cannot find input file: `Makefile.in' ==> ERROR: Se produjo un fallo en build(). Cancelando...

fcolista commented on 2016-02-24 09:35

Hi penetal,
done as you requested.
Thanks for the feedback.
Francesco

penetal commented on 2016-02-24 03:08

Hey, could you add a post_remove to cvechecker.install that removes the groups etc you added on install?

Also the Upstream URL is outdated, it should probably point to the same github repo.

fcolista commented on 2013-02-05 22:03

If possibile, someone may provide some comments if mysql support is needed. Thanks!