Package Details: cuda-8.0 8.0.61-3

Git Clone URL: https://aur.archlinux.org/cuda-8.0.git (read-only, click to copy)
Package Base: cuda-8.0
Description: NVIDIA's GPU programming toolkit. Version 8.0
Upstream URL: http://www.nvidia.com/object/cuda_home.html
Licenses: custom:NVIDIA
Provides: cuda-sdk, cuda-toolkit
Replaces: cuda-sdk, cuda-toolkit
Submitter: clbuttic
Maintainer: clbuttic
Last Packager: clbuttic
Votes: 4
Popularity: 0.000000
First Submitted: 2017-10-27 07:08
Last Updated: 2017-10-27 07:08

Required by (7)

Sources (4)

Latest Comments

u666sa commented on 2021-03-23 09:26

`Yea, this package does not compile. However, it doesn't mean that it isn't useful.

Proper installation in 2021: Download base installer Download patch2

Extract base installer and then extract cuda installer and copy this file InstallUtils.pm into /usr/share/perl5/core_perl

Make base installer and patch2 executable and then Install base installer without nvidia drivers, all default locations, samples in /usr/local/cuda-8.0/samples (you will have to use switch to ignore gcc version, run it with --help to find out what it is) Install patch2

Change gcc version for cuda sudo ln -s /usr/bin/gcc-5 "/usr/local/cuda-8.0/bin/gcc" sudo ln -s /usr/bin/g++-5 "/usr/local/cuda-8.0/bin/g++"

Apply float.h fix sudo sed -i "1 i#define _BITS_FLOATN_H" "/usr/local/cuda-8.0/include/host_defines.h"

Download and save cuda-findgllib_mk.diff Right from your shell inside directory with the above file (zsh for me, doesn't work in fish) for f in /usr/local/cuda-8.0/samples///findgllib.mk; do sudo patch $f cuda-findgllib_mk.diff done

Then we add path to /etc/environment PATH=/usr/local/cuda-8.0/bin:/usr/local/cuda-8.0/samples/bin/x86_64/linux/release:$PATH GLPATH=/usr/lib CUDADIR=/usr/local/cuda

Then we add path to /etc/ld.so.conf /usr/local/cuda-8.0/lib64

type sudo ldconfig

then reboot

then go to /usr/local/cuda-8.0/samples sudo make `

LEXUGE commented on 2019-08-08 10:40

gcc5 unsupported

clbuttic commented on 2018-01-26 07:44

@tinytangent: A vote for cudnn-8.0, then?

tinytangent commented on 2018-01-25 03:47

Seems that this package is conflict with the official cuda. And the official cudnn is based on CUDA 9.1, so maybe it's better to create package a cudnn for CUDA 8.0.