Package Details: csvkit-git 1.0.5.r1.g178eb76-1

Git Clone URL: (read-only, click to copy)
Package Base: csvkit-git
Description: A suite of utilities for converting to and working with CSV
Upstream URL:
Licenses: MIT
Conflicts: csvkit
Provides: csvkit
Submitter: mszczepanczyk
Maintainer: severach (caleb)
Last Packager: caleb
Votes: 12
Popularity: 0.000265
First Submitted: 2013-04-09 12:52
Last Updated: 2020-05-29 13:29

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

kamazee commented on 2015-09-16 20:16

@pmedina, done, check it out.

Looks like it doesn't make much sense to build it from git because there has been no new commits for several months, so fetching the whole repo doesn't seem necessary anymore. I switch PKGBUILD to tarball and add a checksum for 0.9.1, so now it's only about 3 Mb of source code + md5 check to make sure it's downloaded properly.
I'll switch back to git master when it's updated.

pmedina commented on 2015-09-16 19:29

Had to change the source for it to work behind my proxy to the following:


Can you please change in the PKGBUILD?

kamazee commented on 2015-05-12 15:46

@IwfY, thanks, added this workaround for PKGBUILD.

IwfY commented on 2015-05-12 15:26

You can add this at line 26 to fix openpyxl dependency:

sed -i 's/openpyxl==2.2.0-b1/openpyxl>=2.2.0-b1/'

tantalum commented on 2015-04-23 17:17

trying to use csvcut in any way i get:

pkg_resources.DistributionNotFound: The 'openpyxl==2.2.0-b1' distribution was not found and is required by csvkit

kamazee commented on 2015-03-26 10:17

So, until the author upgrades dateutil, here is a PKGBUILD that does patching for you:

jtroesemeier commented on 2015-03-21 10:41


there is an easy but dirty fix I used: just edit the /usr/lib/python3.4/site-packages/csvkit-1.0.0-py3.4.egg-info/requires.txt and replace python-dateutil==2.2 with python-dateutil>=2.2

Alternatively, you could downgrade to python-dateutil 2.2


PS: The maintainer writes on the git issues page:

"[...] dateutil has previously introduced breaking changes rather suddenly so I've been leery of the >= spec. I'll take a look at 2.3 and likely upgrade. Thanks for opening an issue!"

jtroesemeier commented on 2015-03-21 10:38


there is an easy but dirty fix I used: just edit the /usr/lib/python3.4/site-packages/csvkit-1.0.0-py3.4.egg-info/requires.txt and replace python-dateutil==2.2 with python-datautil>=2.2


pmedina commented on 2014-12-16 23:07

There seems to be a conflict with the latest version of 'python-dateutil'

[pmedina@laptop ~]$ csvgrep
Traceback (most recent call last):
File "/usr/lib/python3.4/site-packages/", line 432, in _build_master
File "/usr/lib/python3.4/site-packages/", line 741, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.4/site-packages/", line 632, in resolve
raise VersionConflict(tmpl % args)
pkg_resources.VersionConflict: python-dateutil 2.3 is installed but python-dateutil==2.2 is required by ['csvkit']

khughitt commented on 2014-07-29 14:24

Python 3 now supported: