Package Details: cryptomator 1.5.15-2

Git Clone URL: https://aur.archlinux.org/cryptomator.git (read-only, click to copy)
Package Base: cryptomator
Description: Multiplatform transparent client-side encryption of your files in the cloud.
Upstream URL: https://cryptomator.org/
Keywords: cryptography encryption
Licenses: GPL3
Submitter: Foxboron
Maintainer: ajgraves (overheadhunter, SailReal)
Last Packager: SailReal
Votes: 62
Popularity: 0.89
First Submitted: 2016-04-03 17:36
Last Updated: 2021-05-02 20:37

Dependencies (8)

Required by (0)

Sources (5)

Pinned Comments

ajgraves commented on 2021-05-02 20:49

Everyone, with great thanks to @SailReal, this package now builds Cryptomator from source. If you wish to continue using the binary AppImage build, you need only to install cryptomator-bin.

We made this change to better align with the desires of the community (you've asked a few times to make this a "build from source" package) as well as better align to the package naming convention within the AUR.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

ajgraves commented on 2019-12-31 00:40

Hello @matthias.lisin, apologies for the delay. I'm looking at this now, and cloned your git repo and was able to successfully build the package. I'd feel better if @overheadhunter gave it a look over as well, as I'm not the strongest at Java. It seems to have worked ok as far as I can tell.

Anonymous comment on 2019-12-30 12:14

@ajgraves, I realized that just now, even opened an issue on Github and shortly after reading that the 1.4.16 and 1.4.17 were hotfixes for macOS users only. Once again, apologies for the confusion.

ajgraves commented on 2019-12-30 11:59

I unflagged this package as being out of date, as the latest AppImage version available from upstream is 1.4.15. Version 1.4.17 is only available on the Mac platform.

matthias.lisin commented on 2019-12-07 14:37

Hello @ajgraves and @overheadhunter, I have mailed you my build-from-source proposal two weeks ago. Didn't get any reply.

Here is my proposal in a codeberg.org git repo: https://codeberg.org/ml/cryptomator/commit/65b5bb50ead25c1209e1e1186a57a1c2caf47d39

It would be nice if anyone could review it and give me some feedback.

ajgraves commented on 2019-11-22 04:27

@matthias.lisin, evaluations of doing so are being made.

matthias.lisin commented on 2019-11-16 01:51

Can you rename this package to cryptomator-bin or build the application from source?

davidpblcrd commented on 2019-10-12 08:53

@ajgraves I added _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=default to my /etc/enviroment file and it worked. I'm using mainline Arch with XFCE. Thanks

ajgraves commented on 2019-10-11 23:06

@davidpblcrd, check this forum post that may be helpful: https://bbs.archlinux.org/viewtopic.php?id=248524

Aside from that, as all this package does is installs/runs the AppImage provided by Cryptomator, then you'd need to open an issue upstream at https://github.com/cryptomator/cryptomator/issues

What DE/WM are you running? Is this on mainline Arch or on an Arch derivative?

davidpblcrd commented on 2019-10-11 17:45

I get this error when I try to open the program: https://privatebin.net/?f2c20cd6cb33a797#3hqqHUfDrh7VWPuFbA4d11BzA9aNBZ8CaT1APnK1n852 I tried to install java-openjfx because I thought that the issue was with JavaFX fonts but it didn`t work.

sseneca commented on 2019-09-09 22:43

I've re-written the PKGBUILD to avoid the use of an AppImage and build from source instead, which is of course preferable.

Check it out here: https://gitlab.com/sseneca/cryptomator-pkgbuild/tree/master