Package Details: crosstool-ng-git 1:1.24.0.r150.g4e5bc436-1

Git Clone URL: https://aur.archlinux.org/crosstool-ng-git.git (read-only, click to copy)
Package Base: crosstool-ng-git
Description: crosstool-NG aims at building toolchains.
Upstream URL: http://crosstool-ng.org/
Licenses: GPL
Conflicts: crosstool-ng
Provides: crosstool-ng
Submitter: intelfx
Maintainer: graysky
Last Packager: graysky
Votes: 19
Popularity: 0.63
First Submitted: 2014-07-01 09:24
Last Updated: 2020-08-30 10:33

Latest Comments

1 2 3 4 Next › Last »

graysky commented on 2020-08-15 09:35

@intelfx - sure, you can transfer ownership to me

intelfx commented on 2020-08-15 04:36

@graysky Thanks for the heads-up. Done.

Would you maybe like to comaintain or take over this package? In fact I'm not even using crosstool-ng anymore.

graysky commented on 2020-08-12 18:37

@intelfx - Looks like we have gcc-10.2.0-1 in [staging] now. PR#1338 has been superseded it seems by PR#1368 which patches it up to gcc v10.2.0 and binutils v2.35. Please adjust the PKGBUILD to patch 1368 instead of 1338.

Reference: https://github.com/crosstool-ng/crosstool-ng/pull/1368

Builds fine for me making this change. Thanks!

intelfx commented on 2020-05-26 23:45

@graysky Fixed, thank you.

graysky commented on 2020-05-14 12:08

@intelfx - 1268 got merged upstream back in Dec so you can probably remove the line pulling it. I do recommend that you add https://github.com/crosstool-ng/crosstool-ng/pull/1338 to the PKGBUILD since it adds support for gcc 10.1.0 which is currently in [core].

intelfx commented on 2019-11-09 09:12

@graysky sorry -- both AUR notifications somehow ended up in my junk folder. Package bumped and updated.

graysky commented on 2019-11-09 06:55

Here is a patch: https://gist.github.com/graysky2/c54caf4e3532692dd17756bb5af58d22

graysky commented on 2019-11-05 12:28

@intelfx - Can you please add this following patch which is needed for binutils 2.33.1 ... it is currently "approved" but not yet merged:

https://patch-diff.githubusercontent.com/raw/crosstool-ng/crosstool-ng/pull/1268.patch

petronny commented on 2018-05-01 05:53

checking for unzip... no
configure: error: missing required tool: unzip

Seems that unzip should be a dependency now

intelfx commented on 2018-04-22 12:10

@sudokamikaze Sorry for the latency. Fixed now.