Package Details: crossover 18.5.0-1

Git Clone URL: https://aur.archlinux.org/crossover.git (read-only)
Package Base: crossover
Description: Run Windows Programs on Linux
Upstream URL: http://www.codeweavers.com
Licenses: custom:CrossOver Linux License Grant
Replaces: crossover-games, crossover-pro, crossover-standard
Submitter: ying
Maintainer: roadrunner
Last Packager: roadrunner
Votes: 209
Popularity: 0.81
First Submitted: 2012-03-14 16:03
Last Updated: 2019-03-27 06:41

Dependencies (82)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

ZeroBit commented on 2015-03-18 21:05

The following error occurs during update:
==> Making package: crossover 14.0.3-1 (Wed March 18 23:03:28 EET 2015)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: lib32-libgphoto2
error: target not found: lib32-libexif
error: target not found: lib32-sane
error: target not found: lib32-libxxf86dga

ZeroBit commented on 2014-11-15 13:04

User Bazon shared with me the last compiled package which is needed
https://dl.dropboxusercontent.com/u/932514/Other/lib32-gstreamer0.10-base-plugins-0.10.36-6-x86_64.pkg.tar.xz

So, the full list of binaries is:
https://dl.dropboxusercontent.com/u/12168886/arch/lib32-gstreamer0.10-0.10.36-4-x86_64.pkg.tar.xz
https://dl.dropboxusercontent.com/u/12168886/arch/lib32-gstreamer0.10-base-0.10.36-6-x86_64.pkg.tar.xz
https://dl.dropboxusercontent.com/u/932514/Other/lib32-gstreamer0.10-base-plugins-0.10.36-6-x86_64.pkg.tar.xz

Download it and then do the command:
pacman -U lib32-gstreamer0.10 lib32-gstreamer0.10-base lib32-gstreamer0.10-base-plugins

ZeroBit commented on 2014-11-14 09:54

All needed binary packages is included in 3rd side repo. Edit /etc/pacman.conf and add:
[alucryd-multilib]
SigLevel = Optional TrustAll
Server = http://pkgbuild.com/~alucryd/$repo/x86_64

After that you can build crossover 14.0.1 successfully

ZeroBit commented on 2014-11-14 09:12

User Bozon provided some binaries:

If it is useful for anyone: Ready-built package:
https://dl.dropboxusercontent.com/u/12168886/arch/lib32-gstreamer0.10-base-0.10.36-6-x86_64.pkg.tar.xz
Install with sudo pacman -U lib32-gstreamer0.10-base-0.10.36-6-x86_64.pkg.tar.xz

Note: You have to install the dependency lib32-gstreamer0.10-0.10.36-4 FIRST!
https://dl.dropboxusercontent.com/u/12168886/arch/lib32-gstreamer0.10-0.10.36-4-x86_64.pkg.tar.xz
Install with sudo pacman -U lib32-gstreamer0.10-0.10.36-4-x86_64.pkg.tar.xz
Status: Works for me.

The last package lib32-gstreamer0.10-base-plugins is needed.

jc61990 commented on 2014-11-14 00:53

crossover does not build due to lib32-gstreamer0.10. I was able to edit the pkgbuild for lib32-gstreamer0.10 to have it compile, but lib32-gstreamer0.10-base and lib32-gstreamer0.10-base-plugins seem to still have problems. Can this package use the newer gstreamer rather that 0.10?

ZeroBit commented on 2014-10-17 07:01

New version is available!

orschiro commented on 2014-10-02 05:39

Compiling the lib32 dependencies leads to several errors. Some of them cannot be easily build.

Is there a compiled binary package available for crossover or does someone mind sharing his package?

Thanks ahead!

jpsimard commented on 2014-08-28 11:30

Crossover has a lot of code that is Python 2. The correct depedency is not "python" but "python2". Please modify the PKGBUILD accordingly.

IlyaGulya commented on 2014-08-08 10:24

yeah, here's correct PKGBUILD for now: http://pastebin.com/6N7Jn7ym

derHutschi commented on 2014-08-08 05:01

seems to be that lib32-uitl-linux-ng is a dependency for x86_64 but has been removed from aur or renamed to lib32-util-linux