Package Details: creduce 2.10.0-1

Git Clone URL: https://aur.archlinux.org/creduce.git (read-only)
Package Base: creduce
Description: A C/C++ program reducer
Upstream URL: https://embed.cs.utah.edu/creduce/
Licenses: custom:University of Illinois Open Source License
Submitter: tavianator
Maintainer: tavianator
Last Packager: tavianator
Votes: 5
Popularity: 0.000017
First Submitted: 2015-05-17 16:18
Last Updated: 2019-05-16 15:52

Latest Comments

tavianator commented on 2018-02-10 17:07

@marehr: Thanks for the report, should be fixed!

marehr commented on 2018-01-24 12:00

Currently, the standard compiler is clang-5.x in arch. But, creduce 2.7 is depending on clang-4.x/llvm-4.x. upstream has an open issue to bump it to llvm 5.x https://github.com/csmith-project/creduce/issues/147.

It seems that the recent master branch already fixed this issue and is using llvm 5.x by default. Could you change the source to a snapshot from the github repository?

tavianator commented on 2017-07-21 15:35

@jschievink: Looks like perl-benchmark-timer is missing a dependency on perl-module-install. Take it up with the maintainer of perl-benchmark-timer!

jschievink commented on 2017-07-21 15:29

I'm getting this error when trying to install this:

error: target not found: perl-benchmark-timer

Running pacaur -S perl-benchmark-timer then gives this error:

Can't locate inc/Module/Install.pm in @INC (you may need to install the inc::Module::Install module) (@INC contains: private-lib /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl) at Makefile.PL line 8.
BEGIN failed--compilation aborted at Makefile.PL line 8.

sebo commented on 2016-05-14 16:25

NB: looks like the new version 2.5.0 doesn't depend on delta.