Package Details: cppman 0.5.1-2

Git Clone URL: https://aur.archlinux.org/cppman.git (read-only, click to copy)
Package Base: cppman
Description: C++ 98/11/14 manual pages for Linux/MacOS
Upstream URL: https://github.com/aitjcize/cppman
Licenses: GPL3
Conflicts: cppman-git
Submitter: aitjcize
Maintainer: motte
Last Packager: motte
Votes: 32
Popularity: 0.000252
First Submitted: 2012-09-19 06:00
Last Updated: 2020-08-19 22:24

Latest Comments

avemilia commented on 2020-08-19 16:13

LGTM. Sorry for the initial harsh comment. I couldn't believe that this package had broken man page and completion for (probably 8) years and maintainer(s) were fine with it, as if they don't use the package themselves. Especially since upstream permissions are broken, or maybe it's just python shenanigans.

Now, the zsh completion still doesn't work, but that seems to be an upstream issue. Will investigate further a bit later. As of right now, considering it has a perl call, I would expect perl to be at least an optional dependency.

motte commented on 2020-08-17 19:38

@avemilia I fixed the issues, let me know if anything could be improved.

avemilia commented on 2020-08-16 22:57

Zsh completion is installed in the wrong place. It should be in /usr/share/zsh/site-functions. And it has wrong permissions. Man page has wrong permissions. It should be 644.

This package is very low-effort. Please fix it or delete it.

cherichy commented on 2019-06-20 20:14

Please update the PKGBUILD for 0.5.0, the version 0.4.8 now is out of date.

mar04 commented on 2014-10-12 20:10

It seems like cppman.1.gz is installed with wrong permissions - 640.

aitjcize commented on 2013-11-11 03:14

no, please do so.

paraxor commented on 2013-11-10 17:55

Mind if I send a request for this package to be merged into cppman?

aitjcize commented on 2013-01-12 18:36

The new package can be found in the following link:
https://aur.archlinux.org/packages/cppman/

aitjcize commented on 2012-09-19 05:54

This package is no longer maintained.
manpages-cpp project is renamed to cppman, please search for `cppman' and install it instead.