Package Details: cpplint 456.r43-1

Git Clone URL: https://aur.archlinux.org/cpplint.git (read-only, click to copy)
Package Base: cpplint
Description: Automated checker to make sure a C++ file follows Google's C++ style guide.
Upstream URL: https://google.github.io/styleguide/cppguide.html
Licenses: custom:BSD3
Submitter: liganic
Maintainer: vith
Last Packager: vith
Votes: 34
Popularity: 0.000000
First Submitted: 2012-05-30 19:12
Last Updated: 2020-07-29 09:56

Dependencies (2)

Required by (0)

Sources (1)

Pinned Comments

kgizdov commented on 2019-10-18 09:34

I made cpplint-py3 from the fork, so people can choose.

EDIT: cpplint-py3 is now python-cpplint in [community]. You should be upgraded automatically. If you still wish to use this package, you are free to do so, however, be aware that Arch Linux will eventually drop Python 2.

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

jichu4n commented on 2016-04-29 00:06

The files appear to have changed again. I'm getting the following sha256 checksums:

21898350f6c9b293758e3a55c63ef5531dde1c0b468ff1ca4cc401f68004e9d0 cpplint.py
a2a49a15fc0db21a0c130e57fb5894954d81bc95962fc90be2e70d2daaa27d89 README

acgtyrant commented on 2015-12-09 05:55

vote!

liganic commented on 2015-11-18 21:31

Updated, sorry for the delay.

i_magnific0 commented on 2015-11-18 12:50

Thanks buglloc, replacing the sources works.

README has changed though, so the new sha256sum is:
3a6ce0d4007b6d3dac0925ecf2c5f40e9f8ab50dfcc1fd1caad349b5e8ba7a40

buglloc commented on 2015-11-16 08:03

Build failed:
==> Making package: cpplint 9-0 (Mon Nov 16 09:56:44 EET 2015)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Downloading cpplint.py...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading cpplint.py
Aborting...



Seems "google-styleguide.googlecode.com" was moved to GitHub:
$ http -h https://google-styleguide.googlecode.com
HTTP/1.1 302 Found
Alt-Svc: quic=":443"; p="1"; ma=604800
Alternate-Protocol: 443:quic,p=1
Content-Length: 67
Content-Type: text/html; charset=utf-8
Date: Mon, 16 Nov 2015 08:01:11 GMT
Location: https://code.google.com/p/google-styleguide/
Server: GFE/2.0
X-Content-Type-Options: nosniff
X-Frame-Options: SAMEORIGIN
X-Xss-Protection: 1; mode=block


$ http -h https://code.google.com/p/google-styleguide/
HTTP/1.1 301 Moved Permanently
Cache-Control: public, max-age=2592000
Content-Length: 233
Content-Type: text/html; charset=UTF-8
Date: Mon, 16 Nov 2015 08:01:18 GMT
Expires: Wed, 16 Dec 2015 08:01:18 GMT
Location: https://github.com/google/styleguide
Server: codesite
X-Content-Type-Options: nosniff
X-Frame-Options: SAMEORIGIN
X-XSS-Protection: 1; mode=block


Probably, this is correct source urls:
https://github.com/google/styleguide/raw/gh-pages/cpplint/README
https://github.com/google/styleguide/raw/gh-pages/cpplint/cpplint.py

olantwin commented on 2015-01-29 19:49

Thank you for the quick fix. Works.

liganic commented on 2015-01-29 19:48

I pushed a fixed version, everything should work after you update.
Thanks for the report!

olantwin commented on 2015-01-29 14:46

Since the last update cpplint does not seem to work (no output at all), unless I call it incorrectly, in which case it gives me the help message.
Anyone else have the problem? I can't find a changelog, so hard to tell what the problem could be.

liganic commented on 2015-01-28 22:40

Updated, sorry for the delay.

zbb commented on 2014-12-22 20:46

cpplint.py is failing the validity check when I try to install.