Package Details: cowrie-git 1.1.0+1352+115ccd6-2

Git Clone URL: https://aur.archlinux.org/cowrie-git.git (read-only, click to copy)
Package Base: cowrie-git
Description: Medium interaction SSH honeypot designed to log brute force attacks and entire shell interaction
Upstream URL: https://github.com/micheloosterhof/cowrie
Licenses: BSD
Conflicts: cowrie
Provides: cowrie
Submitter: anthraxx
Maintainer: anthraxx
Last Packager: anthraxx
Votes: 4
Popularity: 0.000003
First Submitted: 2015-07-28 15:07
Last Updated: 2016-12-18 12:23

Latest Comments

kleph commented on 2018-02-25 16:34

Hi,

I finally decided to repair my kippo/cowrie setup. I foudn that the PKGBUILD was not up-to-date with the git anymore.

Here's the few updates I did to fix it. I moved back cowrie.cfg in /opt/cowrie/etc since start.sh does not exists anymore and I did not find a new way to specify the config file location.

-backup=('etc/cowrie.cfg')
+backup=('opt/cowrie/etc/cowrie.cfg')

-  sed -r 's|(cowrie)$|\1 -c /etc/cowrie.cfg|g' -i start.sh

-  install -Dm 644 cowrie.cfg.dist "${pkgdir}/etc/cowrie.cfg"
-  install -Dm 644 doc/COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+  install -Dm 640 cowrie.cfg.dist "${pkgdir}/opt/cowrie/etc/cowrie.cfg"
+  install -Dm 644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"

bastelfreak commented on 2016-11-11 13:02

Hi,
I'm unable to build the PKGBUILD in a clean nspawn container:

==> Extracting sources...
-> Creating working copy of cowrie git repo...
Cloning into 'cowrie-git'...
done.
==> Starting prepare()...
sed: can't read utils/*.py: No such file or directory
==> ERROR: A failure occurred in prepare().

Full logs at:
https://ci.virtapi.org/job/Arch_Package_cowrie-git/2/console

nashley commented on 2016-10-22 20:57

Needs to depend on python2-cryptography
Needs to get the latest version of cowrie (even though the latest and only release is from 2015)

NeoSonic commented on 2016-03-10 15:37

cowrie.service need change add " -c /etc/cowrie.cfg" to ExecStart