Package Details: corsix-th 0.63-1

Git Clone URL: https://aur.archlinux.org/corsix-th.git (read-only)
Package Base: corsix-th
Description: Reimplementation of the game engine of Theme Hospital
Upstream URL: https://github.com/CorsixTH/CorsixTH
Keywords: simulation
Licenses: MIT
Submitter: vesath
Maintainer: carstene1ns
Last Packager: carstene1ns
Votes: 69
Popularity: 0.099492
First Submitted: 2010-06-07 15:48
Last Updated: 2019-06-11 21:42

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

dobo commented on 2013-04-12 17:20

vesath: Actually it wasn't my intention make you change this PKGBUILD. I just wanted to inform other people that it is also possible. I didn't test performance between lua51 and luajit but luajit is recommended by Corsix-TH developers. Have a nice day :).

vesath commented on 2013-04-10 08:46

dobo: Would you care telling us why one would choose luajit over lua51? I've compiled corsix-th against luajit but I see no improvement on CPU usage...

dobo commented on 2013-04-08 12:15

You can use luajit instead of lua51. Look at PKGBUILD diff https://gist.github.com/dobo90/5336363

dobo commented on 2013-04-08 12:12

You can also use luajit instead of lua51. Look at PKGBUILD diff:
https://gist.github.com/anonymous/5336351

ChemBro commented on 2013-03-25 10:43

Version 0.20 is out. Besides that: Shouldn't there be an optional dependency for "timidity-freepats", because otherwise, the music won't play (at least not for me).

vesath commented on 2012-12-16 22:57

ChemBro: Next time when reporting bugs prepend "LANG=C" to the build command; this way you will get the original English compiler messages that everyone can understand.

ChemBro commented on 2012-12-16 13:49

Okay, this is how it worked for me: Completely scrapped the package, edited in PKGBUILD lua51 instead of lua (dep) and removed lua (corsix-th needs lua51, but can't build, if lua is installed).

After that, it worked. Lua 5.2 isn't supported by corsix-th at the moment.

ChemBro commented on 2012-12-15 13:24

Can't build it. I get this:

/home/christian/aur/corsix-th/src/CorsixTH-0.11-Source/CorsixTH/Src/th_lua.cpp:59:29: Fehler: »lua_getenv« wurde in diesem Gültigkeitsbereich nicht definiert (Error: »lua_getenv« was not defined in this "range of validity")
/home/christian/aur/corsix-th/src/CorsixTH-0.11-Source/CorsixTH/Src/th_lua.cpp: In Funktion »int luaT_setfenv52(lua_State*, int)«:
/home/christian/aur/corsix-th/src/CorsixTH-0.11-Source/CorsixTH/Src/th_lua.cpp:94:29: Fehler: »lua_setenv« wurde in diesem Gültigkeitsbereich nicht definiert (Error: »lua_setenv« was not defined in this "range of validity")
make[2]: *** [CorsixTH/CMakeFiles/CorsixTH.dir/Src/th_lua.cpp.o] Fehler 1 (error 1)
make[1]: *** [CorsixTH/CMakeFiles/CorsixTH.dir/all] Fehler 2 (error 2)
make: *** [all] Fehler 2 (error 2)

vesath commented on 2012-09-21 03:07

Zann: Would you ask nicely?

Zann commented on 2012-09-21 02:56

0.01b have been released for a long time now. Would you update?