Package Details: coreclr-git b8cf76e-1

Git Clone URL: https://aur.archlinux.org/coreclr-git.git (read-only)
Package Base: coreclr-git
Description: The .NET Core Runtime
Upstream URL: https://github.com/dotnet/coreclr
Licenses: MIT
Provides: coreclr
Submitter: yuvadm
Maintainer: yuvadm
Last Packager: yuvadm
Votes: 16
Popularity: 0.000000
First Submitted: 2015-02-10 14:46
Last Updated: 2016-03-13 11:52

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

itw commented on 2016-02-19 23:30

If you target an RC2 runtime, DNX and DNU do not work. They do not display errors, they just do nothing. Targeting RC1 seems to work if you have an RC1 project.

simendsjo commented on 2016-01-13 19:00

I get `Error: DownloadPackageAsync ... HTTP request timed out. Exiting` for all packages when building `mscorlib`. I can easily wget the files listen. Any idea what might be wrong?

dshcroer commented on 2016-01-07 18:48

To fix the python2 requirements. Maybe add the following line to the PKGBUILD. Just after line 19.

sed -i 's/python/python2/g' build.sh

lnicola commented on 2015-12-31 14:04

I need to patch build.sh to use python2.

yuvadm commented on 2015-12-16 08:28

Thanks Marqin, I agree debugging tools are an important addition to the package and I won't omit them for no good reason.

Marqin commented on 2015-12-15 16:18

Also, You should add
depends=('icu' 'lldb' 'libunwind' 'lttng-ust')
because produced libraries depend on those libs, and won't run if those are not installed on target OS.

Also, This package have one optional makedepend. It's mono. You have to decide - you want this to build mscorlib.dll, which will be build automatically if someone has mono and add it to makedepends, or you don't want it - then disable it with skipmscorlib switch to build.sh:
sh build.sh skipmscorlib

Btw. some of those libs you are putting in pkg are just for debuging coreclr, but I'm not sure if ommiting them would be good.

Marqin commented on 2015-12-14 23:13

Also, You should change clang and llvm to clang35 and llvm35, because coreclr does not build on newer clang: https://github.com/dotnet/coreclr/issues/2135

Marqin commented on 2015-12-08 13:00

Please add git to makedepends. Without adding it there package will not build in Clean Chroot ( https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_Clean_Chroot ).

EDIT 1:

Also You have to add lttng-ust ( which people that build need to install via AUR ) to makedepend, because without it coreclr will not build.

EDIT 2:

And it seems that 'icu' is also needed ( it's available via pacman )

avkonarev commented on 2015-05-01 11:36

Also, you need to add to the list 'makedepends' of 'llvm': package requires 'llvm-ar'

avkonarev commented on 2015-05-01 11:29

Also, you need to add to the list "makedepends" of "llvm":