Package Details: core 7.2.1-1

Git Clone URL: https://aur.archlinux.org/core.git (read-only, click to copy)
Package Base: core
Description: Common Open Research Emulator
Upstream URL: https://github.com/coreemu/core/
Keywords: emulator
Licenses: BSD
Submitter: tom5760
Maintainer: tom5760
Last Packager: tom5760
Votes: 11
Popularity: 0.008380
First Submitted: 2010-10-27 16:52
Last Updated: 2020-09-29 16:03

Latest Comments

1 2 3 Next › Last »

tom5760 commented on 2020-08-17 18:47

Thanks again @Ruckikir, package is updated now.

tom5760 commented on 2020-08-17 15:54

Cool! Thanks for your help @Rucikir! I was running into similar issues with Poetry. I'll update shortly.

Rucikir commented on 2020-08-17 15:50

Hi! I tried to update the PKGBUILD for CORE 7.0.1, but I don’t get how to tell poetry to fetch the python module dependencies from the system and to install the 'core' module in the system. For now, poetry installs all the modules in ~/.cache. See https://gist.github.com/MisterDA/28b9bb2ef5e05a734de7b8e214ba14eb.

EDIT: I ditched poetry during the installation to use python-dephell, setuptools, and the Arch python-* packages. It should be fine now.

tom5760 commented on 2020-07-28 16:29

CORE 7.0.0 changed a bit with the installation, will need to rework the PKGBUILD a bit. Will try to get to it this weekend.

tom5760 commented on 2020-02-10 15:42

Done, thanks for the catch Rucikir!

Rucikir commented on 2020-02-08 12:50

Thanks for the update! Dependency 'python-yaml' is missing for the new GUI.

gbianchini commented on 2017-06-07 09:15

@Tom5760 Worked like a charm! Thanks!

tom5760 commented on 2017-06-06 23:28

@gbianchini, looks like adding "-no-int-in-bool-context" fixes the build. I've made that change, and updated the PKGBUILD.

gbianchini commented on 2017-06-06 22:59

There's a bug with a python library that doesn't allow me compile it
(Tried it on 2 computers already).

Here's the stack trace:

building 'netns' extension
creating build
creating build/temp.linux-x86_64-2.7
gcc -pthread -DNDEBUG -march=x86-64 -mtune=generic -O2 -pipe -fstack-
protector-strong -Wno-strict-aliasing -O3 -Werror -Wall -D_GNU_SOURCE
-Wno-strict-aliasing -fPIC -I/usr/include/python2.7 -c netnsmodule.c
-o build/temp.linux-x86_64-2.7/netnsmodule.o
In file included from /usr/include/python2.7/Python.h:78:0,
from netnsmodule.c:16:
netnsmodule.c: En la función ‘netns_nsexecvp’:
/usr/include/python2.7/pymem.h:97:30: error: ‘*’ en contexto boolean;
se sugiere ‘&&’ en su lugar [-Werror=int-in-bool-context]
( (type *) PyMem_MALLOC((n) * sizeof(type)) ) )
^
/usr/include/python2.7/pymem.h:75:15: nota: en definición de macro
‘PyMem_MALLOC’
: malloc((n) ? (n) : 1))
^
netnsmodule.c:61:10: nota: en expansión de macro ‘PyMem_NEW’
argv = PyMem_NEW(char *, argc + 1);
^~~~~~~~~
cc1: todos los avisos se tratan como errores
error: command 'gcc' failed with exit status 1
make[3]: *** [Makefile:684: libnetns.a] Error 1
make[3]: se sale del directorio
'/home/german/Documents/core/src/core-4.8/daemon/src'
make[2]: *** [Makefile:624: all-recursive] Error 1
make[2]: se sale del directorio
'/home/german/Documents/core/src/core-4.8/daemon'
make[1]: *** [Makefile:440: all-recursive] Error 1
make[1]: se sale del directorio
'/home/german/Documents/core/src/core-4.8'
make: *** [Makefile:370: all] Error 2
==> ERROR: Se produjo un fallo en build().
Cancelando…

Thanks.

chepaz commented on 2015-01-18 14:01

It works, thank you very much!