Package Details: coot 0.8.9.1-4

Git Clone URL: https://aur.archlinux.org/coot.git (read-only)
Package Base: coot
Description: Crystallographic Object-Oriented Toolkit for model building, completion and validation
Upstream URL: http://lmb.bioch.ox.ac.uk/coot/
Keywords: science
Licenses: GPL
Replaces: coot-data
Submitter: Athemis
Maintainer: Athemis
Last Packager: Athemis
Votes: 1
Popularity: 0.000000
First Submitted: 2016-01-12 02:53
Last Updated: 2019-09-13 12:31

Required by (0)

Sources (14)

Pinned Comments

Athemis commented on 2018-07-10 19:44

Binary packages of coot and its dependencies can be found in my repo. Add these lines to your /etc/pacman.conf:

[home_Athemis_coot_Arch]
SigLevel = Never
Server = https://download.opensuse.org/repositories/home:/Athemis:/coot/Arch/$arch

And install coot via pacman -Syu & pacman -S coot

Latest Comments

1 2 Next › Last »

archiebald commented on 2019-09-17 01:54

Thanks, works great!

Athemis commented on 2019-09-16 10:58

@archiebald: A new binary package is now available. Have fun ;)

archiebald commented on 2019-09-14 14:57

Hi Athemis - My coot-0.8.9.1-3 installed from your binaries on repo home_Athemis_coot_Arch recently stopped working. I see there has been an update to coot-0.8.9.1-4. Would you be able to update your binary packages in your repo as well? I see some of them have recently been updated (e.g. mmdb2). Your help is much appreciated!

Athemis commented on 2019-09-13 11:48

@ywen232625: rdkit-python2 has been fixed in the latest AUR version (depends on python2-cairo now). However, coot will most likely fail to build against this version. You'll need to edit the version in the python2-rdkit PKGBUILD to read "2017_09_03" and then either regenerate the source hashes (install pacman-contrib package and run "updpkgsums") or ignore them (makepkg --skipinteg).

ywen232625 commented on 2019-08-06 16:12

Hi, I have some trouble when trying to install rdkit-python2, it shows that I need to install "python2-cairocffi" in order to install rdkit-python2. And I found that there is no way to install python2-cairocffi. Can you help me out? Thanks in advance

archiebald commented on 2018-10-14 02:45

[SOLVED] Hardware stereo is working now. Had to turn of compositor in KDE Plasma.

@Athemis: Thanks for making your binaries available. Things work fine on my system except for stereo. Can anyone confirm that hardware stereo is actually working with this build?

nmruser commented on 2018-07-31 20:56

@Athemis Thanks, works like charm!

Athemis commented on 2018-07-10 19:44

Binary packages of coot and its dependencies can be found in my repo. Add these lines to your /etc/pacman.conf:

[home_Athemis_coot_Arch]
SigLevel = Never
Server = https://download.opensuse.org/repositories/home:/Athemis:/coot/Arch/$arch

And install coot via pacman -Syu & pacman -S coot

Athemis commented on 2018-07-10 11:04

@nmruser: haven't made any progress so far. I had it building successfully with rdkit-python2-2017_09_3 some time ago. Since then gcc version was bumped which is my best guess what's causing the problems with building against legacy rdkit.

I'll keep you updated on my progress.

UPDATE: The error in dynarama-main seems to be related to glibc-2.26: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=887632

UPDATE 2: The latest revision builds again (at least for me). Please test.

UPDATE 3: Binary packages available (see sticky comment)

nmruser commented on 2018-07-05 14:17

@Athemis, I cannot compile even if I revert to rdkit-python2_2017. Having trouble with dynarama, relevant lines seem to be:

... In file included from /usr/include/gtk-2.0/gtk/gtk.h:173, from dynarama-main.cc:36:

make[1]: [Makefile:1625: dynarama-main.o] Error 1 make: [Makefile:705: all-recursive] Error 1 ==> ERROR: A failure occurred in build(). Aborting...