Package Details: conky19-lua-nv 1.9.0-9

Git Clone URL: https://aur.archlinux.org/conky19-lua-nv.git (read-only, click to copy)
Package Base: conky19-lua-nv
Description: An advanced system monitor for X based on torsmo with lua and nvidia enabled
Upstream URL: http://conky.sourceforge.net/
Licenses: custom
Conflicts: conky
Provides: conky, conky-lua
Replaces: conky, torsmo
Submitter: Foucault
Maintainer: Foucault
Last Packager: Foucault
Votes: 4
Popularity: 0.000000
First Submitted: 2015-07-20 17:14
Last Updated: 2015-12-05 10:17

Latest Comments

1 2 Next › Last »

d_fajardo commented on 2020-07-07 17:59

Thanks Foucault. It does seem to be a linking error - conky trying to install some objects that already exist. I'm not sure why conky-lua-nv doesn't work for me. First of all, converting my old syntax to the new is problematic, then my cpu lua rings don't render (literally frozen) and the ${top mem 1} function renders inf (infinite memory). But conky19 I don't have any problem (except for building it now). I appreciate the help.

Foucault commented on 2020-07-07 17:39

OK it's obviously a linking error. This does not explain why (or when) it started appearing when it used to build properly. I can't debug now but I'll see what I can do. Bear in mind that this is still unmaintained software and it's not expected to build forever even after patches.

d_fajardo commented on 2020-07-07 17:04

Thanks for your reply Foucault. I actually had conky19-nv-lua installed at first and it was working fine. I then decided to update to conky-nv-lua and it didn't work very well. Some of the lua scripyts were not rendering properly so I decided to go back to conky19.

I'm not entirely sure whjat is preventing the build since as I said it was already working before. I believe it has something to do with /usr/bin/ld and here are some of them:

/usr/bin/ld: conky-specials.o:(.bss+0x18): multiple definition of ifup_strictness'; conky-ibm.o:(.bss+0x0): first defined here /usr/bin/ld: conky-temphelper.o:(.bss+0x0): multiple definition ofifup_strictness'; conky-ibm.o:(.bss+0x0): first defined here /usr/bin/ld: conky-timeinfo.o:(.bss+0x4): multiple definition of ifup_strictness'; conky-ibm.o:(.bss+0x0): first defined here /usr/bin/ld: conky-algebra.o:(.bss+0x0): multiple definition ofifup_strictness'; conky-ibm.o:(.bss+0x0): first defined here /usr/bin/ld: conky-proc.o:(.bss+0x0): multiple definition of ifup_strictness'; conky-ibm.o:(.bss+0x0): first defined here /usr/bin/ld: conky-user.o:(.bss+0x0): multiple definition ofifup_strictness'; conky-ibm.o:(.bss+0x0): first defined here /usr/bin/ld: conky-top.o:(.bss+0x0): multiple definition of `ifup_strictness'; conky-ibm.o:(.bss+0x0): first defined here

Foucault commented on 2020-07-07 12:21

Unless you require conky 1.9 for some reason, I suggest you try conky-lua-nv instead. That being said could you please provide some more errors because as it it's not very useful?

d_fajardo commented on 2020-07-06 22:57

I am trying to install this package but I am getting these errors:

collect2: error: ld returned 1 exit status make[2]: [Makefile:685: conky] Error 1 make[2]: Leaving directory '/home/brightchip/.cache/yay/conky19-lua-nv/src/conky-1.9.0/src' make[1]: [Makefile:583: all] Error 2 make[1]: Leaving directory '/home/brightchip/.cache/yay/conky19-lua-nv/src/conky-1.9.0/src' make: *** [Makefile:471: all-recursive] Error 1 ==> ERROR: A failure occurred in build(). ' Any help?

F1nny commented on 2015-12-05 17:57

Yup all good now, thanks Foucault for maintaining!

Foucault commented on 2015-12-05 10:18

Build should be working now.

F1nny commented on 2015-12-05 00:09

Anyone else getting any weird errors RE lua lately? Not sure when it started but suddenly conky stopped working throwing a bunch of errors related to unable to parse lua in the scripts/conkyrc's, when I tried reinstalling this package it's not able to finish configuring as it can't seem to find tolua++ even though it is definitely installed, any ideas?

checking for tolua++... no
checking for tolua++5.1... no
checking for tolua++-5.1... no
configure: error: tolua++, tolua++5.1, or tolua++-5.1 is required for Lua extras.

% pacman -Qs tolua
community/tolua++ 1.0.93-2
Tool to integrate C/C++ code with Lua

//edit:
Also note lua, lua51, and lua52 all installed as well. Weird as no major/minor version increases in anything lua related recently that I can tell, only the following which look to be more patch/bugfix release but maybe something interfered, also tried compiling on another computer with a working conky-lua but same issue (when building conky19-lua-nv)
[2015-11-27 18:47] [ALPM] upgraded tolua++ (1.0.93-1 -> 1.0.93-2)
[2015-12-03 13:47] [ALPM] upgraded lua (5.3.1-1 -> 5.3.2-1)

ondoho commented on 2015-09-19 08:58

this seems to be the best package providing conky 1.9.x atm.
(anyway, i use nvidia, so for me it is)
and i managed to tweak the PKGBUILD so that i can install it alongside conky 1.10
i think this will be necessary for some time, because the new and old syntax are incompatible.
here it is: http://pastebin.com/6QbZMtBD
it's not perfect, but mainstream conky does not complain when i installed it after this one.
provides a "conky19" binary in your $PATH, and some other "conky19" files.

toppy commented on 2015-08-18 13:49

[SOLVED]

Thank you Foucault ! Installed perfectly. Really appreciate the fast response.
Regards
Toppy