Package Details: conky-nvidia 1.11.4-1

Git Clone URL: https://aur.archlinux.org/conky-nvidia.git (read-only)
Package Base: conky-nvidia
Description: Lightweight system monitor for X
Upstream URL: http://conky.sourceforge.net/
Licenses: GPL, BSD
Conflicts: conky
Provides: conky
Submitter: None
Maintainer: sakalisc
Last Packager: sakalisc
Votes: 123
Popularity: 0.036488
First Submitted: 2008-08-17 12:22
Last Updated: 2019-06-24 09:22

Latest Comments

1 2 3 4 5 6 ... Next › Last »

sakalisc commented on 2019-06-11 16:19

I double-checked to make sure and it looks like I confused devtools with base-devel. Git is not part of base-devel, so I've added it as a make dependency. Apologies to wuestengecko for ignoring it the first time.

Kage-Yami commented on 2019-06-11 07:49

Regarding not including git as part of makedepends... while this does fall into the realm of AUR helpers, things like aurutils/aurto will fail to build the package if git is missing from makedepends, as they build each AUR package within a clean chroot.

(aurto creates a local package repository and automatically rebuilds explicitly marked AUR packages on a set schedule into the local repository - this repository is just then accessed like any other via pacman. Very nice for AUR packages that take a long time to build, as it's already built by the time you're updating it on your system [e.g. handbrake-*].)

sakalisc commented on 2019-03-17 13:56

I've added libpulse, thanks for letting me know. Git is part of devtools, so it shouldn't be an explicit dependency.

wuestengecko commented on 2019-03-17 13:28

cmake will complain if git and libpulse are not available in the build environment, and fail. Please add them to makedepends and depends respectively.

sakalisc commented on 2018-12-17 17:00

@mtyacorn I have updated the PKGBUILD to reflect the flags used in [extra].

mtyacorn commented on 2018-12-15 23:28

Would you mind adding Pulse Audio as a build option? I think it would be more consistent considering the official repository has conky built with it enabled. It's not a very difficult change to the PKGBUILD to enable it, and it would give the wiki more consistency.

sakalisc commented on 2018-12-09 15:06

@Buddlespit pkgconf is part of based-devel, which is assumed to be already installed when building with makepkg.

Buddlespit commented on 2018-12-06 10:47

pkgconf needed to be added as dependencies for this to build

sakalisc commented on 2018-12-05 19:38

Please note: https://github.com/brndnmtthws/conky/issues/520

sakalisc commented on 2017-11-04 16:14

@ABOhiccups, what is the issue you are having?