Package Details: conky-lua 1.11.3-1

Git Clone URL: https://aur.archlinux.org/conky-lua.git (read-only)
Package Base: conky-lua
Description: Lightweight system monitor for X, with Lua support enabled
Upstream URL: http://github.com/brndnmtthws/conky
Keywords: conky conky-lua
Licenses: GPL3, BSD
Conflicts: conky
Provides: conky=1.11.3
Submitter: alexiobash
Maintainer: oberon2007
Last Packager: oberon2007
Votes: 55
Popularity: 1.69
First Submitted: 2015-08-12 18:00
Last Updated: 2019-02-26 20:35

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

oberon2007 commented on 2017-05-29 01:00

Looks like conky devs needs to fix their code...
https://github.com/brndnmtthws/conky/issues/396

oberon2007 commented on 2017-05-29 00:05

I see, so you are on testing and gcc 7 is the issue... Will try to fix it.

wsgdlhy commented on 2017-05-28 23:43

ya -Ss gcc
testing/gcc 7.1.1-2 (base-devel) [installed]
The GNU Compiler Collection - C and C++ frontends
testing/gcc-ada 7.1.1-2
Ada front-end for GCC (GNAT)
testing/gcc-fortran 7.1.1-2
Fortran front-end for GCC
testing/gcc-go 7.1.1-2
Go front-end for GCC
testing/gcc-libs 7.1.1-2 (base) [installed]
Runtime libraries shipped by GCC
testing/gcc-objc 7.1.1-2
Objective-C front-end for GCC
core/gcc 6.3.1-2 (base-devel) [installed: 7.1.1-2]
The GNU Compiler Collection - C and C++ frontends
core/gcc-ada 6.3.1-2
Ada front-end for GCC (GNAT)
core/gcc-fortran 6.3.1-2
Fortran front-end for GCC
core/gcc-go 6.3.1-2
Go front-end for GCC
core/gcc-libs 6.3.1-2 (base) [installed: 7.1.1-2]
Runtime libraries shipped by GCC

wsgdlhy commented on 2017-05-28 23:37

/tmp/yaourt-tmp-fu/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:39:15: 错误:‘function’ in namespace ‘std’ does not name a template type
typedef std::function<int(state *)> cpp_function;
^~~~~~~~
/tmp/yaourt-tmp-fu/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:243:30: 警告:dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
void checkstack(int extra) throw(std::bad_alloc);
^~~~~
/tmp/yaourt-tmp-fu/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:250:26: 错误:‘cpp_function’ does not name a type; did you mean ‘lua_CFunction’?
void pushclosure(const cpp_function &fn, int n);
^~~~~~~~~~~~
lua_CFunction
/tmp/yaourt-tmp-fu/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:251:27: 错误:‘cpp_function’ does not name a type; did you mean ‘lua_CFunction’?
void pushfunction(const cpp_function &fn) { pushclosure(fn, 0); }
^~~~~~~~~~~~
lua_CFunction
/tmp/yaourt-tmp-fu/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:255:46: 警告:dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
void rawgetfield(int index, const char *k) throw(std::bad_alloc);
^~~~~
/tmp/yaourt-tmp-fu/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:257:46: 警告:dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
void rawsetfield(int index, const char *k) throw(std::bad_alloc);
^~~~~
/tmp/yaourt-tmp-fu/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:279:39: 警告:dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
void loadfile(const char *filename) throw(lua::syntax_error, lua::file_error, std::bad_alloc);
^~~~~
/tmp/yaourt-tmp-fu/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:280:34: 警告:dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
void loadstring(const char *s) throw(lua::syntax_error, std::bad_alloc);
^~~~~
/tmp/yaourt-tmp-fu/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:283:44: 错误:‘cpp_function’ does not name a type; did you mean ‘lua_CFunction’?
void register_fn(const char *name, const cpp_function &f) { pushfunction(f); setglobal(name); }
^~~~~~~~~~~~
lua_CFunction
/tmp/yaourt-tmp-fu/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:289:35: 警告:dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
std::string tostring(int index) throw(lua::not_string_error);
^~~~~
make[2]: *** [src/CMakeFiles/conky.dir/build.make:87:src/CMakeFiles/conky.dir/colours.cc.o] 错误 1
make[1]: *** [CMakeFiles/Makefile2:526:src/CMakeFiles/conky.dir/all] 错误 2
make: *** [Makefile:152:all] 错误 2
==> 错误: 在 build() 中发生一个错误。
正在放弃...
==> 错误:Makepkg 无法构建 conky-lua.

oberon2007 commented on 2017-05-28 09:06

@bmbaker The package builds just fine for me. What version of gcc do you have installed?

bmbaker commented on 2017-05-28 08:02

there seems to a error in the build!

[ 30%] Building CXX object src/CMakeFiles/conky.dir/colours.cc.o
In file included from /tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/update-cb.hh:39:0,
from /tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/text_object.h:35,
from /tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/common.h:34,
from /tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/conky.h:37,
from /tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/colours.cc:30:
/tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/semaphore.hh:40:36: warning: dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
semaphore(unsigned int value = 0) throw(std::logic_error)
^~~~~
/tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/semaphore.hh:49:14: warning: dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
void post() throw(std::overflow_error)
^~~~~
In file included from /tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/setting.hh:32:0,
from /tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/common.h:35,
from /tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/conky.h:37,
from /tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/colours.cc:30:
/tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:39:15: error: ‘function’ in namespace ‘std’ does not name a template type
typedef std::function<int(state *)> cpp_function;
^~~~~~~~
/tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:243:30: warning: dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
void checkstack(int extra) throw(std::bad_alloc);
^~~~~
/tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:250:26: error: ‘cpp_function’ does not name a type; did you mean ‘lua_CFunction’?
void pushclosure(const cpp_function &fn, int n);
^~~~~~~~~~~~
lua_CFunction
/tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:251:27: error: ‘cpp_function’ does not name a type; did you mean ‘lua_CFunction’?
void pushfunction(const cpp_function &fn) { pushclosure(fn, 0); }
^~~~~~~~~~~~
lua_CFunction
/tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:255:46: warning: dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
void rawgetfield(int index, const char *k) throw(std::bad_alloc);
^~~~~
/tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:257:46: warning: dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
void rawsetfield(int index, const char *k) throw(std::bad_alloc);
^~~~~
/tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:279:39: warning: dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
void loadfile(const char *filename) throw(lua::syntax_error, lua::file_error, std::bad_alloc);
^~~~~
/tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:280:34: warning: dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
void loadstring(const char *s) throw(lua::syntax_error, std::bad_alloc);
^~~~~
/tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:283:44: error: ‘cpp_function’ does not name a type; did you mean ‘lua_CFunction’?
void register_fn(const char *name, const cpp_function &f) { pushfunction(f); setglobal(name); }
^~~~~~~~~~~~
lua_CFunction
/tmp/yaourt-tmp-bb/aur-conky-lua/src/conky-1.10.6/src/luamm.hh:289:35: warning: dynamic exception specifications are deprecated in C++11 [-Wdeprecated]
std::string tostring(int index) throw(lua::not_string_error);
^~~~~
make[2]: *** [src/CMakeFiles/conky.dir/build.make:87: src/CMakeFiles/conky.dir/colours.cc.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:526: src/CMakeFiles/conky.dir/all] Error 2
make: *** [Makefile:152: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build conky-lua.

oberon2007 commented on 2017-05-23 00:38

Thanks @fcolista. I've adopted the pkg

fcolista commented on 2017-02-09 09:45

Hi.
This PKGBUILD seems abandoned, the maintainer does not respond.

A new PKGBUILD can be downloaded here, if needed:

https://github.com/fcolista/aur/blob/master/conky-lua/PKGBUILD

bastelfreak commented on 2016-09-25 13:22

Hi,
I'm unable to build the PKGBUILD in a fresh arch nspawn container:
https://ci.virtapi.org/job/Arch_Package_conky-lua/21/console

logs:
-- Checking for one of the modules 'lua=5.1;lua5.1;lua-5.1'
CMake Error at /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:646 (message):
None of the required 'lua=5.1;lua5.1;lua-5.1' found
Call Stack (most recent call first):
cmake/ConkyPlatformChecks.cmake:252 (pkg_search_module)
CMakeLists.txt:37 (include)


-- Checking for modules 'cairo;cairo-xlib'
-- Found cairo, version 1.14.6
-- Found cairo-xlib, version 1.14.6
-- Checking for module 'imlib2'
-- Found imlib2, version 1.4.9
-- Checking for module 'librsvg-2.0'
-- No package 'librsvg-2.0' found
CMake Error at /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:424 (message):
A required package was not found
Call Stack (most recent call first):
/usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:597 (_pkg_check_modules_internal)
cmake/ConkyPlatformChecks.cmake:274 (pkg_check_modules)
CMakeLists.txt:37 (include)


-- Configuring incomplete, errors occurred!
See also "/build/conky-lua/src/conky-1.10.1/CMakeFiles/CMakeOutput.log".
See also "/build/conky-lua/src/conky-1.10.1/CMakeFiles/CMakeError.log".
==> ERROR: A failure occurred in build().

zuzavo commented on 2016-08-13 22:03

I've installed first git, then pacman -U lua51-5.1.5-4-x86_64.pkg.tar.xz, and installation works fine. After installation there's no problem tu update lua