Package Details: colout-git r247.438838d-1

Git Clone URL: https://aur.archlinux.org/colout-git.git (read-only, click to copy)
Package Base: colout-git
Description: Reads text on stdin and produces colorized and stylized output
Upstream URL: http://nojhan.github.com/colout/
Keywords: color terminal theming
Licenses: GPL
Conflicts: colout
Provides: colout
Submitter: jle64
Maintainer: YeahSure
Last Packager: YeahSure
Votes: 16
Popularity: 0.001979
First Submitted: 2013-04-04 21:35
Last Updated: 2021-03-11 22:07

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

YeahSure commented on 2021-03-11 23:03

@fartreason

Thanks for the heads up.

Of the 3, the only one I had installed was python-pip and after uninstalling it, it didn't want to build as it now looks for the pip version to install. So you are right, it looks like it is now needed.
I do not have the other 2 pkgs you listed installed on my system and the pkg still builds fine.
Since I am in the U.S. I am unsure about python-babel being needed, but went ahead and updated the PKGBUILD to include it as an optional, just in case. Also going to keep python-pygments as optional for the time being.

Have a good one!

fartreason commented on 2021-03-11 10:02

Hi, I think some polish is due for dependencies:

  • python-pip is needed as makedep.
  • python-pygments is listed as optional dep, but it does not seem to be optional
  • python-babel should at least be an optional dep (I do need it for the program to work on a non-English locale).

jle64 commented on 2017-03-17 01:55

@xpixelz: I disowned the package as I don't actually use it, feel free to fix it.

xpixelz commented on 2017-03-16 06:36

Won't work unless following packages installed :
$ sudo pip install pysigset requests-unixsocket blessed flask-restful scruffington

jle64 commented on 2015-06-09 07:47

@TrialnError: should be better now. Thx.

TrialnError commented on 2015-06-08 12:10

Since pacman 4.1 the handling of VCS sources changed significantly

https://wiki.archlinux.org/index.php/VCS_package_guidelines

jle64 commented on 2013-11-09 10:58

@alkino: Updated to make pygments an optdepends, thx. Concerning your other issue there is nothing I can do, I'm just making the PKGBUILD, you should see that with the software author.

alkino commented on 2013-11-04 23:27

python-pygments seems to be an "optdepends" instead of a "depends".

More over the domain of gcc (in /usr/lib/python3.3/site-packages/colout/colout_g++.py) seems to be "gcc" and not `"gcc-"+gv`. But I can't test because I got problem of utf-8 after...

jle64 commented on 2013-06-09 13:25

@mihai303: Updated, thanks. I didn't see that a setup.py had been added.

Anonymous comment on 2013-06-07 09:32

Consider using the standard install rule in order to avoid future work on the packaging part. Thanks for the PKGBUILD.

package() {
cd "$srcdir/$pkgname"
python setup.py install --root="$pkgdir/" --optimize=1
}