Package Details: collabora-online-server-nodocker 4.2.0-2

Git Clone URL: https://aur.archlinux.org/collabora-online-server-nodocker.git (read-only, click to copy)
Package Base: collabora-online-server-nodocker
Description: Collabora CODE (LibreOffice Online) server for Nextcloud or ownCloud, without Docker
Upstream URL: https://www.collaboraoffice.com/code/
Licenses: MPL
Provides: libreoffice, libreoffice-en-US
Submitter: theYinYeti
Maintainer: theYinYeti
Last Packager: theYinYeti
Votes: 8
Popularity: 0.015378
First Submitted: 2017-10-13 20:12
Last Updated: 2019-12-29 20:56

Required by (48)

Sources (20)

Pinned Comments

theYinYeti commented on 2018-01-04 08:33

About upstream: 1º Upstream does not maintain past versions of packages, so I have no choice but to follow new releases. 2º Upstream does not advertise minor/patch releases. These are the reasons why the PKGBUILD is made to adapt itself the best it can to the current upstream situation, whatever it is. If an incompatible change occurs, do not hesitate to mark the package as “obsolete”: I will get notified, and fix the the package as soon as my free time allows. Cheers :-)

Latest Comments

1 2 3 Next › Last »

genofire commented on 2020-04-02 16:10

A hint how to add other languages and dict support ?

hhirtz commented on 2020-01-24 12:55

Line 155 of PKGBUILD should be mv lib/* usr/lib && rmdir lib instead of mv {lib,usr/lib}, because usr/lib already exists. It fixes usr/lib/systemd/system/loolwsd.service not found.

theYinYeti commented on 2020-01-07 07:22

@itbane: At what step (makepkg, systemd journal, log file…) did you notice that libxrender1 is missing, and with what version? I just rebuilt on my computer, and I don’t see libxrender1 missing. And on my server, loolwsd.service is running without any error related to that.

However, I did remove all X11 desktop entries from the latest release, because I saw that they were broken, and I thought that was an upstream choice (these are not needed for LibreOffice On-Line). Is that what you mean?

itbane commented on 2020-01-02 15:44

Hi, upstream has added a new dependency for "libxrender1"[1]. Please update the package accordingly. Thanks!

[1]https://bugs.documentfoundation.org/show_bug.cgi?id=115277

x-f commented on 2019-12-28 02:50

6.2 is released

grondinm commented on 2019-12-03 11:34

Thank you for this package.

In my experience the following lines where not needed

the usr/lib/libPoco* from this

chmod a+x opt/collaboraoffice6.0/program/lib.so usr/lib/libPoco usr/share/applications/*.desktop

and

mv usr/lib{/lib,}/systemd rmdir usr/lib/lib

After those lines removed/modified package installed fine and as far as i can tell everything works 100%

genofire commented on 2019-09-17 14:22

install script shows wrong path to cert creation:

/usr/share/doc/loolwsd/mkcert_example.sh

should be:

/usr/share/doc/loolwsd/example.mkcert.sh

this file should be installed with 755

install -Dm0644 "$srcdir"/mkcert_example.sh usr/share/doc/loolwsd/example.mkcert.sh


bugfix in example.mkcert.sh:

openssl genrsa -out "certs/servers/localhost/privkey.pem" 2048 -key "certs/servers/localhost/privkey.pem" should be: openssl genrsa -out "certs/servers/localhost/privkey.pem" 2048


it would also be nice, if you announce that in install that a run of is nessasacry:

loolwsd-systemplate-setup /opt/lool/systemplate /opt/collaboraoffice6.0/

toco commented on 2019-08-23 10:36

Hi @YinYeti all good, I compilled it to fix the situation, and later updated ...

Thank you!

theYinYeti commented on 2019-08-16 08:01

Hello @toco, @Arhangel64, poco is now taken from upstream and included into this package. So you should not need to install another poco. Let me know if there still is an issue.

toco commented on 2019-08-13 20:53

oh nooo I had a poco-git pkg before, ver 1.7. Now I don't have the pacman cache and no old version of poco 1.9.0-2 :( Its too bad, I can't find the version in google.

Please help me! ...compile compile