Package Details: codelite 15.0.2-1

Git Clone URL: https://aur.archlinux.org/codelite.git (read-only, click to copy)
Package Base: codelite
Description: Cross platform C/C++/PHP and Node.js IDE written in C++
Upstream URL: http://www.codelite.org/
Keywords: C++ Editor IDE
Licenses: GPL
Submitter: None
Maintainer: uffe
Last Packager: uffe
Votes: 169
Popularity: 0.035047
First Submitted: 2008-08-01 09:11
Last Updated: 2021-06-08 17:21

Pinned Comments

uffe commented on 2016-09-26 11:42

ATTENTION: read this before flagging this package out-of-date

This package "codelite" represents the stable release of the codelite project.

I do not consider the "Weekly Builds" from http://downloads.codelite.org/ as stable releases (neither does the codelite project)

Generally speaking - this package will not be updated before the codelite release/download page (https://downloads.codelite.org/) have a new stable release published.

Please respect that - Thanks

PS: to clear up a recent misunderstanding - this does not mean that I won't accept patches that is needed for stable codelite to build against refreshed libraries etc

PS: I have added new "codelite-unstable" package to AUR that follows the weekly/latest builds from the codelite project.

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10 11 12 13 14 15 Next › Last »

underdoeg commented on 2014-05-05 13:45

Thanks for your answer. Did it build correctly on your machine? I still have the issue and it seems like I am not the only one. These links are related to other wxWidgets enabled projects and gcc 4.9

https://aur.archlinux.org/packages/dolphin-emu-git/?setlang=ja
http://forums.codeblocks.org/index.php?topic=19231.msg131515;topicseen

migrev commented on 2014-05-03 16:46

I have all packages updated and can't reproduce the error. Codelite works just fine.

underdoeg commented on 2014-05-03 16:44

Just tried it on my laptop as well and there I don't have the error. My laptop is not as up to date. But the only update that might be relevant is

core/gcc-libs 4.8.2-8 -> 4.9.0-1
core/gcc 4.8.2-8 -> 4.9.0-1

underdoeg commented on 2014-05-03 11:31

I get this error. Looks like its related to wxgtk.

/home/phwhitfield/softwareSources/codelite-5.4/build-release/lib/libplugin.so: undefined reference to `wxCommandEvent::Clone() const'
collect2: error: ld returned 1 exit status

Grotlek commented on 2014-04-13 03:07

This package ought be in community/extras. It's better by far than some of the alternatives already in there :-). It has my +1.

rprego commented on 2014-01-21 22:46

I think there is not an Arch-compatible wxCrafter library for the current version. I added a bug for it: https://github.com/eranif/codelite/issues/210

rprego commented on 2014-01-17 03:12

I'm on x86_64
Here's the output of ldd /usr/lib/codelite/wxCrafter.so: http://pastebin.com/Nwze5nEF

migrev commented on 2014-01-16 12:25

@rprego: Which architecture do you have (i686 or x86_64)? Can you check if any libs are missing with 'ldd /usr/lib/codelite/wxCrafter.so'? Thanks!

rprego commented on 2014-01-16 04:19

When I create a new wxWidgets project, I get a message that says the wxCrafter plugin is not installed... how do I install it? As far as I can tell, wxcrafter.so is in /usr/lib/codelite. Thanks for any help

migrev commented on 2014-01-13 23:53

Updated to 5.4 along with wxCrafter 1.4

@ghotrix: This also fixes your 404.