Package Details: codelite 13.0-1

Git Clone URL: https://aur.archlinux.org/codelite.git (read-only, click to copy)
Package Base: codelite
Description: Cross platform C/C++/PHP and Node.js IDE written in C++
Upstream URL: http://www.codelite.org/
Keywords: C++ Editor IDE
Licenses: GPL
Submitter: None
Maintainer: uffe
Last Packager: uffe
Votes: 161
Popularity: 0.78
First Submitted: 2008-08-01 09:11
Last Updated: 2019-10-09 22:17

Pinned Comments

uffe commented on 2019-10-09 22:24

Two months have gone - no official ArchLinux or upstream pango/harfbuzz have come up... I've made a temporary hack/patch that again will enable end-users to compile this codelite AUR package without hazzle.

The pkgrel will NOT be bumped - it is a deliberate choise. My change will bring no value to those of you who have managed to build the current release of codelite - and those that have failed to build codelite during the last two months will not be notified by the pkgrel bump anyway....

Please speak up if you think this is wrong :-)

uffe commented on 2016-09-26 11:42

ATTENTION: read this before flagging this package out-of-date

A number of you have recently flagged package out-of-date

This package "codelite" represents the stable release of the codelite project.

I do not consider the "Weekly Builds" from http://downloads.codelite.org/ as stable releases (neither does the codelite project)

Also note: currently codelite weekly builds are only published as binary packages - this package builds from source - you should take a look at the codelite-bin AUR package)

Generally speaking - I will not update this package before the codelite github release page (https://github.com/eranif/codelite/releases) have the release published.

Please respect that - Thanks

You can always do you own "codelite-weekly" AUR package if you like...

PS: to clear up a recent misunderstanding - this does not mean that I won't accept patches that is needed for stable codelite to build against refreshed libraries etc

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

uffe commented on 2016-08-26 18:20

@Gendalf: you have flagged codelite out-of-date - but http://codelite.org/ main-page mentions nothing of Codelite-9.2.1

Generally speaking the github release page (https://github.com/eranif/codelite/releases) needs to have the release published before I will push a new release

Thx/Uffe :-)

zerophase commented on 2016-08-02 03:58

@fusion809 Is Clang 3.8 required to open Codelite? With having Clang as a required dependency it prevents changing Clang versions from the official repos.

fusion809 commented on 2016-08-01 13:26

Ah clang is listed as both an optional and runtime dependency. I think it should be listed as a runtime or optional dependency. As if someone has this package installed and it's a runtime dependency they should already have the package installed and hence it isn't really an optional dependency.

zerophase commented on 2016-07-30 16:45

I'm just referring to clang 3.8 as being a necessary dependency for building the ide. would it make sense to have clang as a makedepend?

uffe commented on 2016-07-30 11:56

Yes, if you have clang-3.5 installed - go into menu Settings -> Build settings...
In the dialog you can scan your computer for the compilers that you have installed.

Select the one you prefer..

zerophase commented on 2016-07-29 23:18

Does 9.2-1 compile with clang 3.5? On occasion I need to drop back to clang 3.5 for a custom Unreal build.

uffe commented on 2016-02-06 00:05

Updated to codelite 9.1.0

norby commented on 2015-10-27 15:41

Thanks, nickname!

I thought that this problem is resolved in the latest version, so I left out the comments.

P.S. Sorry for my bad English :(

nickname commented on 2015-10-26 17:25

Hi norby.
This happens (most probable) because of the lldb 3.7 version.

See the two different solutions uffe provides on the comments below

the other logs (mismatch) are displayed every time anyway

norby commented on 2015-10-26 17:16

The application fails to start:

Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1008,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8)