Package Details: codelite 13.0-1

Git Clone URL: https://aur.archlinux.org/codelite.git (read-only, click to copy)
Package Base: codelite
Description: Cross platform C/C++/PHP and Node.js IDE written in C++
Upstream URL: http://www.codelite.org/
Keywords: C++ Editor IDE
Licenses: GPL
Submitter: None
Maintainer: uffe
Last Packager: uffe
Votes: 161
Popularity: 0.71
First Submitted: 2008-08-01 09:11
Last Updated: 2019-10-09 22:17

Pinned Comments

uffe commented on 2019-10-09 22:24

Two months have gone - no official ArchLinux or upstream pango/harfbuzz have come up... I've made a temporary hack/patch that again will enable end-users to compile this codelite AUR package without hazzle.

The pkgrel will NOT be bumped - it is a deliberate choise. My change will bring no value to those of you who have managed to build the current release of codelite - and those that have failed to build codelite during the last two months will not be notified by the pkgrel bump anyway....

Please speak up if you think this is wrong :-)

uffe commented on 2016-09-26 11:42

ATTENTION: read this before flagging this package out-of-date

A number of you have recently flagged package out-of-date

This package "codelite" represents the stable release of the codelite project.

I do not consider the "Weekly Builds" from http://downloads.codelite.org/ as stable releases (neither does the codelite project)

Also note: currently codelite weekly builds are only published as binary packages - this package builds from source - you should take a look at the codelite-bin AUR package)

Generally speaking - I will not update this package before the codelite github release page (https://github.com/eranif/codelite/releases) have the release published.

Please respect that - Thanks

You can always do you own "codelite-weekly" AUR package if you like...

PS: to clear up a recent misunderstanding - this does not mean that I won't accept patches that is needed for stable codelite to build against refreshed libraries etc

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

zerophase commented on 2016-11-17 20:15

Doesn't work with clang 3.9

duckbrain commented on 2016-11-13 14:48

I am now getting this error:

codelite: error while loading shared libraries: libclang.so.3.8: cannot open shared object file: No such file or directory

It looks like clang updated to 3.9.

jgmdev commented on 2016-10-02 14:13

This is a better description as found on github repo:
"A cross platform C/C++/PHP and Node.js IDE written in C++"

jgmdev commented on 2016-10-01 18:36

Please update the description to:
"A Free, open source, cross platform C,C++,PHP and Node.js IDE" as found on codelite.org site

Since now codelite is more than C/C++ IDE

jgmdev commented on 2016-10-01 18:27

The hunspell package is missing as a dependency, and it is needed for the spellchecker plugin.

uffe commented on 2016-09-26 11:43

@pattisahusiwa: please read the newly pinned comment on codelite stable releases

/thanks :-)

uffe commented on 2016-09-26 11:42

ATTENTION: read this before flagging this package out-of-date

A number of you have recently flagged package out-of-date

This package "codelite" represents the stable release of the codelite project.

I do not consider the "Weekly Builds" from http://downloads.codelite.org/ as stable releases (neither does the codelite project)

Also note: currently codelite weekly builds are only published as binary packages - this package builds from source - you should take a look at the codelite-bin AUR package)

Generally speaking - I will not update this package before the codelite github release page (https://github.com/eranif/codelite/releases) have the release published.

Please respect that - Thanks

You can always do you own "codelite-weekly" AUR package if you like...

PS: to clear up a recent misunderstanding - this does not mean that I won't accept patches that is needed for stable codelite to build against refreshed libraries etc

zerophase commented on 2016-09-12 08:33

@zza The only thing I could suggest if you're running out of memory is compiling without -pipe, and maybe try compiling a second time. (Would need to install with makepkg for that I believe, and not yaourt) When I compile Unreal I usually fail the first time, and have to try a second time.

uffe commented on 2016-09-12 08:25

@zza

The error:

*** Error in `/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus': malloc():
smallbin double linked list corrupted: 0x0af423f0 ***

Is an error in the (GCC) c++ compiler backend - it is not related to codelite
The error should be reported to the on the GCC compiler for i686

Codelite is a fairly large C++ project - is your i686 system low on memory or similar ?

Anyway I do not have a i686 system - so I cannot help you here - other than suggesting that you report the error to the GCC folks









zza commented on 2016-09-11 04:59

Attempted to install codelite 9.2-1 (on i686) via command: $ yaourt -S codelite

While compiling received the following error 4% into the compile process:

[ 4%] Building CXX object sdk/wxshapeframework/CMakeFiles/wxshapeframework.dir/src/TextShape.cpp.o
*** Error in `/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus': malloc(): smallbin double linked list corrupted: 0x0af423f0 ***
======= Backtrace: =========
/usr/lib/libc.so.6(+0x67d2a)[0xb73e0d2a]
/usr/lib/libc.so.6(+0x6e9c7)[0xb73e79c7]
/usr/lib/libc.so.6(+0x70c70)[0xb73e9c70]
/usr/lib/libc.so.6(__libc_malloc+0xc5)[0xb73eb3d5]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus(xmalloc+0x18)[0x8d8f5a8]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus(splay_tree_insert+0x43)[0x8d8f093]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus(_Z29maybe_note_name_used_in_classP9tree_nodeS0_+0x78)[0x8274268]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus[0x82ae42e]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus[0x82ae6e0]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus[0x82b9f5d]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus[0x829d58d]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus[0x82ae5fe]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus[0x82b82b4]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus[0x82b876d]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus[0x82bef95]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus[0x82bdafa]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus(_Z12c_parse_filev+0x25b)[0x82bde0b]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus(_Z19c_common_parse_filev+0xdc)[0x838449c]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus[0x8704d0e]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus(_ZN6toplev4mainEiPPc+0x68f)[0x820c2cf]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus(main+0x31)[0x820e391]
/usr/lib/libc.so.6(__libc_start_main+0xf6)[0xb7391196]
/usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus[0x820e785]
======= Memory map: ========
08048000-0986b000 r-xp 00000000 08:01 916019 /usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus
0986b000-0986f000 r--p 01822000 08:01 916019 /usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus
0986f000-09877000 rw-p 01826000 08:01 916019 /usr/lib/gcc/i686-pc-linux-gnu/6.1.1/cc1plus
09877000-0996c000 rw-p 00000000 00:00 0
0ac60000-0aff0000 rw-p 00000000 00:00 0 [heap]
ae600000-ae621000 rw-p 00000000 00:00 0
ae621000-ae700000 ---p 00000000 00:00 0
ae755000-ae771000 r-xp 00000000 08:01 265238 /usr/lib/libgcc_s.so.1
ae771000-ae772000 r--p 0001b000 08:01 265238 /usr/lib/libgcc_s.so.1
ae772000-ae773000 rw-p 0001c000 08:01 265238 /usr/lib/libgcc_s.so.1
ae773000-b243d000 rw-p 00000000 00:00 0
b247d000-b71df000 rw-p 00000000 00:00 0
b71df000-b7377000 r--p 00000000 08:01 279658 /usr/lib/locale/locale-archive
b7377000-b7379000 rw-p 00000000 00:00 0
b7379000-b752b000 r-xp 00000000 08:01 266734 /usr/lib/libc-2.24.so
b752b000-b752c000 ---p 001b2000 08:01 266734 /usr/lib/libc-2.24.so
b752c000-b752e000 r--p 001b2000 08:01 266734 /usr/lib/libc-2.24.so
b752e000-b752f000 rw-p 001b4000 08:01 266734 /usr/lib/libc-2.24.so
b752f000-b7532000 rw-p 00000000 00:00 0
b7532000-b7585000 r-xp 00000000 08:01 268964 /usr/lib/libm-2.24.so
b7585000-b7586000 ---p 00053000 08:01 268964 /usr/lib/libm-2.24.so
b7586000-b7587000 r--p 00053000 08:01 268964 /usr/lib/libm-2.24.so
b7587000-b7588000 rw-p 00054000 08:01 268964 /usr/lib/libm-2.24.so
b7588000-b759e000 r-xp 00000000 08:01 267342 /usr/lib/libz.so.1.2.8
b759e000-b759f000 r--p 00015000 08:01 267342 /usr/lib/libz.so.1.2.8
b759f000-b75a0000 rw-p 00016000 08:01 267342 /usr/lib/libz.so.1.2.8
b75a0000-b75a3000 r-xp 00000000 08:01 268963 /usr/lib/libdl-2.24.so
b75a3000-b75a4000 r--p 00002000 08:01 268963 /usr/lib/libdl-2.24.so
b75a4000-b75a5000 rw-p 00003000 08:01 268963 /usr/lib/libdl-2.24.so
b75a5000-b762d000 r-xp 00000000 08:01 265387 /usr/lib/libgmp.so.10.3.1
b762d000-b762e000 r--p 00087000 08:01 265387 /usr/lib/libgmp.so.10.3.1
b762e000-b762f000 rw-p 00088000 08:01 265387 /usr/lib/libgmp.so.10.3.1
b762f000-b7698000 r-xp 00000000 08:01 267193 /usr/lib/libmpfr.so.4.1.4
b7698000-b7699000 ---p 00069000 08:01 267193 /usr/lib/libmpfr.so.4.1.4
b7699000-b769a000 r--p 00069000 08:01 267193 /usr/lib/libmpfr.so.4.1.4
b769a000-b769b000 rw-p 0006a000 08:01 267193 /usr/lib/libmpfr.so.4.1.4
b769b000-b76b7000 r-xp 00000000 08:01 273424 /usr/lib/libmpc.so.3.0.0
b76b7000-b76b8000 r--p 0001b000 08:01 273424 /usr/lib/libmpc.so.3.0.0
b76b8000-b76b9000 rw-p 0001c000 08:01 273424 /usr/lib/libmpc.so.3.0.0
b76b9000-b76e1000 rw-p 00000000 00:00 0
b76e1000-b76e2000 r--p 00197000 08:01 279658 /usr/lib/locale/locale-archive
b76e2000-b76e4000 rw-p 00000000 00:00 0
b76e4000-b76e6000 r--p 00000000 00:00 0 [vvar]
b76e6000-b76e7000 r-xp 00000000 00:00 0 [vdso]
b76e7000-b7709000 r-xp 00000000 08:01 266733 /usr/lib/ld-2.24.so
b7709000-b770a000 r--p 00021000 08:01 266733 /usr/lib/ld-2.24.so
b770a000-b770b000 rw-p 00022000 08:01 266733 /usr/lib/ld-2.24.so
bf923000-bf945000 rw-p 00000000 00:00 0 [stack]
In file included from /tmp/yaourt-tmp-guest/aur-codelite/src/codelite-9.2/sdk/wxshapeframework/include/wx/wxsf/Printout.h:15:0,
from /tmp/yaourt-tmp-guest/aur-codelite/src/codelite-9.2/sdk/wxshapeframework/include/wx/wxsf/ShapeCanvas.h:24,
from /tmp/yaourt-tmp-guest/aur-codelite/src/codelite-9.2/sdk/wxshapeframework/src/TextShape.cpp:18:
/usr/include/wx-3.0/wx/printdlg.h:61:13: internal compiler error: Aborted
virtual wxPrintDialogData& GetPrintDialogData();
^~~~~~~~~~~~~~~~~
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://bugs.archlinux.org/> for instructions.