Package Details: cockroachdb-bin 20.1.5-1

Git Clone URL: https://aur.archlinux.org/cockroachdb-bin.git (read-only, click to copy)
Package Base: cockroachdb-bin
Description: An open source, survivable, strongly consistent, scale-out SQL database
Upstream URL: https://www.cockroachlabs.com
Keywords: database postgresql RDBMS
Licenses: Apache, custom:BSL, custom:CCL
Conflicts: cockroachdb
Provides: cockroachdb
Submitter: marceloneil
Maintainer: ragouel
Last Packager: ragouel
Votes: 6
Popularity: 0.000000
First Submitted: 2017-02-16 14:00
Last Updated: 2020-09-01 14:08

Latest Comments

Cork commented on 2019-11-23 18:59

The LICENSE file has changed again. Now it is 68040689c4342e0018adec3eb0fb1f2ae68aaeef918e7b4493518523381b7129.

jktr commented on 2019-11-15 13:23

@vasily: Fixed. They've apparently changed their licensing policy.

https://www.cockroachlabs.com/blog/oss-relicensing-cockroachdb/

vasily commented on 2019-11-15 11:29

@jktr Please update the checksum for the LICENSE file. It has changed as well in the new version and now the check fails.

axionl commented on 2018-05-28 13:13

I've been adding this package to archlinuxcn repository, thinks again!

Source

Package URL

jktr commented on 2018-05-27 16:52

@axionl: Thanks for your feedback!

axionl commented on 2018-05-27 06:21

Thanks for you package, but here's some problems here:

===> Waring: ELF file ('usr/bin/cockroach') has executable stack.

  • For this problem, I think create a sof-tlink for ELF file may be better, and put them to /opt path may be a better way.

===> cockroachdb-bin W: Dependency glibc included but already satisfied

  • glibc is a part of base group, so you can remove it from PKGBUILD.

But the more serious problem is that:

==> cockroachdb-bin E: File (etc/cockroach) is owned by root:361

==> cockroachdb-bin E: File (var/lib/cockroach) is owned by 361:361

  • Forcing the designation of owners and groups is not a good idea under the system root. If you can find a better way to fix this problem, please update the PKGBUILD.