Package Details: clipit 1.4.3-2

Git Clone URL: https://aur.archlinux.org/clipit.git (read-only)
Package Base: clipit
Description: Lightweight GTK+ clipboard manager (fork of Parcellite)
Upstream URL: https://github.com/CristianHenzel/ClipIt/
Licenses: GPL3
Submitter: arojas
Maintainer: oberon2007
Last Packager: oberon2007
Votes: 47
Popularity: 2.095635
First Submitted: 2016-11-20 15:08
Last Updated: 2018-08-11 05:59

Latest Comments

1 2 3 Next › Last »

therojam commented on 2019-04-02 08:53

@mranderson17 read what @oberon2007 wrote "It was decided that v1.4.4 was not ok. Nothing has changed in the code since then."

I have also an updated AUR-PKGBUILD -- see my github https://github.com/TheRojam/aur-clipit

mranderson17 commented on 2019-04-02 04:31

Would you mind revisiting this? I got it to build and run just fine with version 1.4.4 using the following updated PKGBUID:

pkgname=clipit
_pkgname=ClipIt
pkgver=1.4.4
pkgrel=1
pkgdesc="Lightweight GTK+ clipboard manager (fork of Parcellite)"
arch=('i686' 'x86_64')
url="https://github.com/CristianHenzel/ClipIt/"
license=('GPL3')
depends=('gtk2' 'libappindicator-gtk2')
makedepends=('intltool')
optdepends=('xdotool: for automatic paste')
source=("${url}/archive/v${pkgver}.tar.gz")
md5sums=('d49b9171c0b81269deafab9d6ecc7610')

build() {
  cd "${srcdir}/${_pkgname}-${pkgver}"
  ./autogen.sh
  ./configure \
    --prefix=/usr \
    --sysconfdir=/etc \
    --enable-appindicator
  make
}

package() {
  cd "${srcdir}/${_pkgname}-${pkgver}"
  make DESTDIR=${pkgdir} install
}

Maybe I have a dependency installed that isn't listed in the documentation? I also tried the --with-gtk3 configure arg but that seems to be broken (doesn't build) unless I'm doing something wrong.

oberon2007 commented on 2019-01-30 12:42

@therojam, please read the comments of last August. It was decided that v1.4.4 was not ok. Nothing has changed in the code since then.

oberon2007 commented on 2018-08-19 11:17

@mokkurkalve, downloads without problem for me.

mokkurkalve commented on 2018-08-18 10:33

Well, I only get "400: Invalid request" on the source file. Can you download it?

8472 commented on 2018-08-12 12:19

@oberon2007, you're right, something wrong with my ISP's DNS. When I switched to something different, it became reachable. Interesting, as I haven't seen any DNS issues with my ISP yet.

oberon2007 commented on 2018-08-12 11:48

The github link works fine. Must be a problem on your end, @8472

8472 commented on 2018-08-12 09:41

Hi, the previous version 1.4.3-2 on URL "https://github.com/CristianHenzel/ClipIt//archive/722fcf73fa0ce8430208c986e50b1c82975de69c.tar.gz" cannot be found.

proft commented on 2018-08-11 20:29

Thanks for previous version (1.4.3-2)! Works like a charm!

oberon2007 commented on 2018-08-11 06:00

Latest git snapshot doesn't even build. Reverted to the old version now.