Package Details: cling-git r4443.9470e538-1

Git Clone URL: https://aur.archlinux.org/cling-git.git (read-only)
Package Base: cling-git
Description: Interactive C++ interpreter built on the top of LLVM and Clang libraries.
Upstream URL: https://root.cern.ch/cling
Licenses: custom:Cling Release License
Submitter: hagabaka
Maintainer: eduardosm
Last Packager: eduardosm
Votes: 42
Popularity: 0.51
First Submitted: 2013-06-08 07:00
Last Updated: 2019-11-16 18:27

Dependencies (7)

Sources (3)

Latest Comments

1 2 3 4 5 Next › Last »

eduardosm commented on 2019-11-16 18:45

@tauroid Thanks, fixed. I wonder why cling needs the NVPTX target.

tauroid commented on 2019-11-16 16:44

CMake Error at tools/cling/CMakeLists.txt:178 (message):
  NVPTX backend is not activated

  Please enable it via -DLLVM_TARGETS_TO_BUILD="host;NVPTX"

changing the relevant line (44) in PKGBUILD yields working install for me

-DLLVM_TARGETS_TO_BUILD="host" \

to

-DLLVM_TARGETS_TO_BUILD="host;NVPTX" \

jdc commented on 2019-04-25 03:14

I ran into a cryptic error message, but found it it was because I didn't have libc++ installed. With that out of the way, it works great!

maximaman commented on 2019-02-02 20:58

I have encountered the following error while trying to build the package:

/home/sid/src/aur/cling-git/src/llvm/tools/cling/lib/Interpreter/Interpreter.cpp: In constructor ‘cling::Interpreter::Interpreter(int, const char* const*, const char*, bool, const cling::Interpreter*)’:
/home/sid/src/aur/cling-git/src/llvm/tools/cling/lib/Interpreter/Interpreter.cpp:309:13: error: ‘class clang::CompilerInvocation’ has no member named ‘addOverlay’
       CInvo.addOverlay(FS);
             ^~~~~~~~~~
In file included from /home/sid/src/aur/cling-git/src/llvm/include/llvm/ADT/STLExtras.h:32,
                 from /home/sid/src/aur/cling-git/src/llvm/include/llvm/ADT/StringRef.h:13,
                 from /home/sid/src/aur/cling-git/src/llvm/tools/cling/include/cling/Interpreter/Interpreter.h:15,
                 from /home/sid/src/aur/cling-git/src/llvm/tools/cling/lib/Interpreter/Interpreter.cpp:10:
/home/sid/src/aur/cling-git/src/llvm/include/llvm/ADT/SmallVector.h: In instantiation of ‘void llvm::SmallVectorTemplateBase<T, true>::push_back(const T&) [with T = std::pair<clang::IdentifierInfo*, clang::SourceLocation>]’:
/home/sid/src/aur/cling-git/src/llvm/tools/cling/lib/Interpreter/Interpreter.cpp:833:53:   required from here

eduardosm commented on 2016-11-25 10:22

@marmistrz Please, try the new version I've just uploaded.

marmistrz commented on 2016-11-24 22:04

error: patch failed: tools/Jupyter/kernel/clingkernel.py:67
error: tools/Jupyter/kernel/clingkernel.py: patch does not apply

eduardosm commented on 2016-04-30 07:39

@pkoretic The error mentioned in the out-of-date message looks like a bug in the tool you are using to install cling.

ralonso commented on 2016-04-11 04:01

It seems the jupyter diff no longer applies to the current git version of tools/Jupyter/kernel/clingkernel.py.

eduardosm commented on 2016-03-23 19:33

@NeoZelux The package is in the base-devel group, and according to the wiki there shouldn't be packages from that group in makedepends.

NeoZelux commented on 2016-03-22 20:58

Hi, I think you should add pkg-config as a build dependency.